SCCM Reports disappearing from console intermittently but working fine from SSRS web portal.

Mayur Anil Gharat 1 Reputation point
2022-11-09T16:48:54.753+00:00

SCCM Reports disappearing from console intermittently but working fine from SSRS web portal. Recently installed SCCM 2207 Server.
Issue: SCCM Reports appears in console for few seconds & then disappears and console shows "no items found", reappears after refreshing console multiple times & disappears again after few seconds. At the same time, below error gets generated in event viewer repetitively.

Please help, need to fix this issue ASAP.

  • SCCM Version is 2207, installed in Azure VM
  • Database & SSRS is installed on another Azure VM
  • Both Servers are running Server 2019 1809 OS & installed with all updates available till today
  • SQL Server is SQL Server 2019 STD 15.0.4261.1 with latest CU installed

258768-ms1.jpg

System.Net.WebException\r\nThe underlying connection was closed: An unexpected error occurred on a receive.\r\n at System.Net.HttpWebRequest.GetResponse()
at Microsoft.ConfigurationManagement.Reporting.Utility.GetFavoriteReportId()
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.FavoritesReportDisplayHelper.FavoriteReportIcon(IResultObject resultObject, String assemblyMethod, AssemblyDescription& resourceAssembly)
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.FavoritesReportDisplayHelper.ShowFavoriteReportIcon(Object sender, ScopeNode scopeNode, IResultObject resultObject, AssemblyDescription& resourceAssembly)\r\nSystem.IO.IOException\r\nUnable to read data from the transport connection: An existing connection was forcibly closed by the remote host.\r\n at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)\r\nSystem.Net.Sockets.SocketException\r\nAn existing connection was forcibly closed by the remote host\r\n at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)\r\n


If i try to run report when its visible in console, (sometime) it runs properly but after some time it throws below error.

258788-ms2.jpg

The underlying connection was closed: An unexpected error occurred on a receive.

-------------------------------

Microsoft.ConfigurationManagement.ManagementProvider.SmsException
The underlying connection was closed: An unexpected error occurred on a receive.

Stack Trace:
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.GetParameters()
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.LoadParameters(IReport report, Collection`1 navigationParameters, IResultObject resultObject)
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ReportViewerPresenter.Worker_DoWork(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

-------------------------------

System.Net.WebException
The underlying connection was closed: An unexpected error occurred on a receive.

Stack Trace:
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.GetParameters()
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.LoadParameters(IReport report, Collection`1 navigationParameters, IResultObject resultObject)
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ReportViewerPresenter.Worker_DoWork(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

-------------------------------

System.IO.IOException
Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

Stack Trace:
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.GetParameters()
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.LoadParameters(IReport report, Collection`1 navigationParameters, IResultObject resultObject)
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ReportViewerPresenter.Worker_DoWork(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

-------------------------------

System.Net.Sockets.SocketException
An existing connection was forcibly closed by the remote host

Stack Trace:
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.GetParameters()
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ParameterPresenter.LoadParameters(IReport report, Collection`1 navigationParameters, IResultObject resultObject)
at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.ReportViewerPresenter.Worker_DoWork(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

-------------------------------

Thanks,
MG

Microsoft Configuration Manager
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. AllenLiu-MSFT 42,011 Reputation points Microsoft Vendor
    2022-11-10T06:45:56.603+00:00

    Hi, @Mayur Anil Gharat

    Thank you for posting in Microsoft Q&A forum.

    You may check if there is an expired certificate on your SQL Server Reporting Services Web Service?
    https://byteben.com/bb/reports-missing-in-the-configuration-manager-console/
    (Please Note: Since the website is not hosted by Microsoft, just for your reference.)


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Garth 5,801 Reputation points
    2022-11-10T10:57:52.417+00:00

    you will need to review the event log on the Ssrs server. additional, you will need to check the health of Sql vm, tls settings, firewall rules, etc. ensure that items like tls match on the console and Ssrs server.


  3. Erick T 0 Reputation points
    2023-03-23T13:31:04.4233333+00:00

    Was this ever resolved? I'm having similar issues with a new install and not finding much on where to look to resolve this. Note that I see those entries in the Event Viewer on the client that has the SCCM Console open attempting to view reports. If I jump onto the SCCM Server and go through the same steps, I have no issue.

    0 comments No comments