Can't control tabbing in Visual Studio Code

Omar 21 Reputation points

When I press Ctrl Tab the windows cycle through most recently used order.
This is winding me up!

So I read up the solution:

To achieve this in Visual Studio Code, you have to edit keybindings.json. Use the Command Palette with CTRL+SHIFT+P, enter "Preferences: Open Keyboard Shortcuts (JSON)", and hit Enter.

Then add to the end of the file:

// ...
"key": "ctrl+tab",
"command": "workbench.action.nextEditor"
"key": "ctrl+shift+tab",
"command": "workbench.action.previousEditor"

That's all good. But then when I try to edit the file, I get this message 'Cannot edit in read-only mode editor'.
OK... so I'll use another editor. I right click on the tab and there is an option 'Open in other editor...' (or something like that). When I click that, nothing happens.

When I search for solutions on 'Cannot edit in read-only mode editor' I get answers to other problems.

Where am I going wrong?

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,753 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anna Xiu-MSFT 27,096 Reputation points Microsoft Vendor

    Hi @Omar ,

    You are using Visual Studio Code, which is different from Visual Studio. The tag “vs-general” is related to Visual Studio, for more questions about Visual Studio Code, please post it to the Stack Overview tagged visual-studio-code forum or GitHub repository where you would get professional support for this product.

    Thanks for your understanding.

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

0 additional answers

Sort by: Most helpful