Hybrid Autopilot 80070002, Timed out waiting for ODJ blob or connectivity

Hong Ye 6 Reputation points

I am currently trying to setup up hybrid autopilot for Intune. I have done the configurations but it lead me to the error code 80070002. Then running the autopilot diagnostics it appears that it was unable to establish connectivity.
The error was "Could not establish connectivity" and "Timed out waiting for ODJ blob or connectivity.

Another question, does the ODJ connect need to be installed on the Domain Controller or it doesn't matter ?

*I am able to ping the domain controller

Can someone help please

Windows Autopilot
Windows Autopilot
A collection of Microsoft technologies used to set up and pre-configure new devices and to reset, repurpose, and recover devices.
426 questions
Microsoft Intune Enrollment
Microsoft Intune Enrollment
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Enrollment: The process of requesting, receiving, and installing a certificate.
1,290 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Crystal-MSFT 45,251 Reputation points Microsoft Vendor

    @Hong Ye , Thanks for posting in Q&A. For the Intune Connector, it is not necessary to install on DC. But it needs to be installed on a computer that's running Windows Server 2016 or later with .NET Framework version 4.7.2 or later. And the computer must have access to the internet and your Active Directory. Here is a link with more details.

    For our issue, please firstly check in Intune portal to see if the Intune Connector is there and active.

    Then check if the network requirements are all met.

    In addition, here is a link with troubleshooting steps. You can read it as a reference:
    Note: Non-Microsoft link, just for the reference.

    Please check the above information and if there's any update, feel free to let us know.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  2. Nils Saligmann 6 Reputation points

    Hi, your autopilot configuration policy needs the on-prem domain name (FQDN) not the AAD one.

    1 person found this answer helpful.