ASR Stop from replicating

Handian Sudianto 4,511 Reputation points
2022-11-10T08:14:41.153+00:00

Hi..

Our ASR often stop replication with error

==========================================================================

High latency observed on disk(s) 'Disk0'. High amount of data is pending for upload.

Possible causes

  1) There is a high amount of data pending for upload due to network latency:  

1. Disk0, DataPendingForUpload : 0Bytes, ObservationTime : 133125311954980636 UTC
2) Bandwidth between source and process server is lower than the data change rate (churn) observed at the source machine.
3) Process Server (PS) is not able to upload to Azure at the required speed.

Recommendation

  1) Increase the bandwidth between source and process server.  
  2) Check if the PS is unhealthy due to low throughput. Increase the bandwidth required to upload data to Azure.  

===========================================================================

When i check in recomendation i not found any issue

  1. Test copy file from source and process server have more than 2Gbps
  2. From PS speed test to internet have more than 100Mbps

So anyone know about this issue?259071-screenshot-2022-11-10-150436.jpg

Azure Site Recovery
Azure Site Recovery
An Azure native disaster recovery service. Previously known as Microsoft Azure Hyper-V Recovery Manager.
681 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. SadiqhAhmed-MSFT 41,716 Reputation points Microsoft Employee
    2022-11-10T19:41:08.643+00:00

    Hi @Handian Sudianto Thank you for reaching out to us with your concern. Would be more than glad to assist you!

    From error details it appears that the issue is caused by high churn rate. These types of errors may also occur if the following limits exceeds:

    . Source IOPS exceeds the supported storage IOPS limit of 7,500 per disk.

    . Source IOPS exceeds the supported storage IOPS limit of 80,000 per VM.

    . Source VM average data churn exceeds the supported Site Recovery data churn limit of 10 MB/s for average I/O size.

    . Source VM average effective write IOPS exceeds the supported Site Recovery IOPS limit of 840.

    . Calculated snapshot storage exceeds the supported snapshot storage limit of 10 TB.

    As a recommendation, I would suggest you select a large premium storage disk as mentioned in the below documentation:

    https://learn.microsoft.com/en-us/azure/site-recovery/site-recovery-vmware-deployment-planner-analyze-report#azure-site-recovery-limits

    The Azure Site Recovery deployment planners (VMware to Azure deployment planner, Hyper-V to Azure deployment planner) help with capacity planning and is a highly recommended pre-step before starting replication.

    Hope this helps!

    ----------------------------------------------------------------------------------------------------------------------

    If the response helped, do "Accept Answer" and up-vote it