Exchange Server is not working when the DC is off

Mikhail Firsov 1,876 Reputation points
2022-11-10T14:27:35.027+00:00

Hello!

There're two DCs (DC and DC2) in a single site and two Exchange Servers 2019 - Exch1 and Exch2.

Initially DC was the PDC and I recently transfered all FSMO to DC2.

The problem: when DC is down Exch2 is not functioning:
259122-01.png

Exch1 does work and is using DC2 as expected:
259095-00-1.png

Seems Exch2 "wants" to talk to only the former pdc - DC, but Get-ExchangeServer ... EXCH2 command shows DC2 in the Originating DC field:

259059-03.png

There're no events 2080 in the log as described here (at least in the Application and System logs).

Why does Exch2 can't "see" the new PDC server (DC2, GC)?

Thank you in advance,
Michael

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,483 questions
{count} votes

Accepted answer
  1. Philippe Levesque 5,706 Reputation points
    2022-11-10T14:42:01.377+00:00

    Hi, The exchange config seem good, but please make sure the Exchange server itself is using DC2 IP for DNS (ipconfig /all). Using the bad DNS configuration will make the server fail more indirect thing like Kerberos auth with client computer.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Mikhail Firsov 1,876 Reputation points
    2022-11-11T08:21:47.623+00:00

    Hello,

    Thank you very much for your replies!

    "is that DC is hard-coded to Exch 2" - no:

    259434-04.png

    "By default, Exchange attempts to connect to a DC that is available on the same site." - agree!

    ...I must apologize for the question... I was so sure my dns settings for BOTH Exchange servers contained IPs of BOTH domain controllers that I couldn't even had imagined Exch2 was missing the second DC's address :(

    "please make sure the Exchange server itself is using DC2 IP for DNS (ipconfig /all)" - that's it!

    259482-05-exch2.png

    Thank you all once again for your help!

    Regards,
    Michael

    1 person found this answer helpful.
    0 comments No comments

  2. LilyLi2-MSFT 1,981 Reputation points
    2022-11-11T06:45:01.383+00:00

    Hi @Mikhail Firsov ,

    By default, Exchange attempts to connect to a DC that is available on the same site.

    Did you hardcode Exch2 to a specific DC? You can check the static domain controller with the following command:

    Get-ExchangeServer -identity <server name> -status | fl *static*  
    

    If you specify the static value, you can use Set-ExchangeServer to set it as the default.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments