Windows 10 (2004) and LSI 9271-8i

Chi Man Erio HO 11 Reputation points
2020-09-26T01:54:12.233+00:00

Hi all,

I recently try to upgrade my workstation from 1909 to 2004 but having following problem.

I have LSI 9271-8i on my workstation, and see my attachment for working configuration.

  • I try to apply the latest update (19041.508) via windows update, but resulting BSOD (page fault in non paged area), I have to rollback to (19041.450), not rollback, but to use clonezilla to resotre, as I can't access the safe mode, bootloop at attempt to repair screen.
  • When I try to clean install 2004, failed with storport.sys BSOD, can't access the very first screen. But I have no problem in 1909 and installed normally.
  • When I detach the RAID elements (unplug all disk), leaving the card on motherboard, It can access the install welcome page, but that's useless as I would like to insall the system on RIAD.
  • When I rebuild all RAID elements, it failed again and it seems not the problem on RAID elements.

My conclusion is, when Windows 2004 use the RAID or try to touch the RAID elements, it failed, not the card nor the elements. Can anyone help me to solve the problem?

28417-pc.xml

Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,912 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. i3v 51 Reputation points
    2021-01-22T20:02:58.233+00:00

    I was also experiencing BSOD (Storport.sys , DRIVER NOT EQUAL OR LESS) when trying to upgrade my Windows 10 1903 to 2004. As well as to 20H2.

    I also have LSI MegaRAID card installed (ASUS Pike 2208, which is effectively the same as LSI MegaRAID 9265-8i; Firmware Package Version 23.16.0-0021; Driver Version 6.714.05.00).

    Upgrading LSI card driver to 6.714.18.0 changed nothing by itself - the next installation attempt failed as well.

    But after I ran "Disk cleanup" with admin permissions (this removed "$WINDOWS.~BT" and etc), the next 20H2 upgrade attempt was successful.

    Thus, @Dale Kudusi is probably right about updating the driver, but the link he provided does no make sense (points to Version 6.504.5.0, A01 , which is very old). The correct download link is this, it provides Version 06.714.18.00.

    PS Here's another my post with effectively the same info.

    5 people found this answer helpful.

  2. Dale Kudusi 3,226 Reputation points
    2020-09-28T09:33:43.643+00:00

    Hi
    You could try updating the LSI 9271-8I driver to the latest version:
    https://www.dell.com/support/home/en-sg/drivers/driversdetails?driverid=1h8pc

    also try performing a SFC scan:
    Open elevated command prompt,
    Type in sfc /scannow, then press Enter.

    Please feel free to let us know if you need further assistance.
    Best regards.

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  3. Mariusz Dullak 11 Reputation points
    2021-03-15T17:50:30.32+00:00

    I am trying to boot Windows 20H2 64bit install and it just reboots automatically.
    As soon as I disconnect the drives it boots OK. But I want to install system on RAID10 connected via this controller.
    I added newest Broadcom drivers to the install image and this does not change anything.

    Looks to me like Windows issue not Broadcom issue.

    BTW: it works on 1909 64bit.

    1 person found this answer helpful.
    0 comments No comments

  4. Juha Vehmanen 1 Reputation point
    2022-11-24T20:57:03.897+00:00

    Just installed the lsi 9271-8i card and windows 10 (22h2) installed automatically "latest" drivers for the card. Version 06.714.20.00

    It seemed fine, but after installing the drives and configuring them through bios, windows would not boot. Taking the drives out let me back to windows. Disabling the card from windows, installing drives and enabling back in windows would result in bsod: storport.sys Irql not less or equal error.

    After installing the proper drivers from previous post (06.714.18.00) fixed the problem!

    0 comments No comments

  5. Andy 0 Reputation points
    2023-10-19T13:31:25.13+00:00

    I was trying to upgrade a Windows 7 system that booted from this controller. I have an SSD as JBOD, a few SAS drives also in JBOD and 3 SAS drives in RAID5. I tried to upgrade using the latest (at this time) 22H2 on an USB flash drive but it failed with an error after the first reboot (0xC1900101 - 0x20017) that googling suggested was a driver incompatibility error. Tried booting from the USB drive and got the bluescreen from storport.sys. Decided to back up the Windows 7 install (just in case) and erase the SSD. I also found that Windows 10 1909 was the latest version that booted properly with these controllers so what worked for me was:

    -Get a copy of Windows 10 1909 using mediacreationtool.bat (it's a script that helps you get whatever version of Windows you like and uses the official MS Media Creation Tool to download it) and write it on a different USB flash drive;

    -Erase the SSD (using a linux distro and ATA security erase feature)

    -Boot from the 1909 USB drive and install that;

    -Update the LSI controller driver with the one mentioned earlier (06.714.18.00), latest from Broadcom's site;

    -Plug in 22H2 USB drive and do the upgrade from within 1909.

    Everything went well so far, all drives recognised (including RAID5 array) and nothing lost. Perhaps it would have worked to upgrade the 7 install to 1909, update the driver and then do the 22H2 update but I'd rather have a clean Windows 10 anyways so I chose to erase the drive since the important stuff was on the other drives anyway and I did a backup in case I forgot something

    Good luck!

    0 comments No comments