Azure Virtual Network Manager Portal screen always time outs whilst trying to find scopes

Ed Oatley 1 Reputation point
2022-11-13T11:03:13.03+00:00

Hello,

I am trying to configure and deploy Azure Virtual Network Manager to better undertsand how it works. I have tried to do this by navigating to https://portal.azure.com/#create/Microsoft.NetworkManager which gives the "Create a network manager" page. There I can select a name, resource group, features and region with no issues. When I click the "Select scopes" it always times out for me with this message:

   {  
    "shellProps": {  
        "sessionId": "bd6d737b2c0f4895bca857119e6e2a37",  
        "extName": "Microsoft_Azure_ManagedNetwork",  
        "contentName": "ScopeSelectorContextPanel.ReactView"  
    },  
    "error": {  
        "message": "Timed Out",  
        "details": "The experience timed out while loading.",  
        "metadata": [  
            {  
                "id": "Render time",  
                "loading": false  
            },  
            {  
                "id": "ReduxFreeDecorator",  
                "loading": true  
            }  
        ],  
        "code": null  
    }  
}  

Any ideas why this might be happening or how I can debug this issue? I did click on the perform self diagnostics and it all passed with no issues. I also managed to deploy a network manager with terraform AzApi:

resource "azapi_resource" "network_manager" {  
  type      = "Microsoft.Network/networkManagers@2022-05-01"  
  name      = "networkmanager"  
  parent_id = azurerm_resource_group.vnrg.id  
  location  = azurerm_resource_group.vnrg.location  
  
  body = jsonencode({  
    properties = {  
      networkManagerScopeAccesses = [  
        "Connectivity",  
        "SecurityAdmin"  
      ]  
      networkManagerScopes = {  
        subscriptions = [  
          data.azurerm_subscription.current.id  
        ]  
      }  
    }  
  })  
}  

The problem with terraform was that I could not get the configurations to deploy correctly so to troubleshoot that I want to get Virtual Network Manager working in the portal first and then work on the terraform definitions.

Welcom any advice on steps I can take to fix this

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,289 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. JimmySalian-2011 42,066 Reputation points
    2022-11-13T12:43:36.187+00:00

    Hi,

    As the Azure Network Manager is currently in the preview mode and certain features as usual they do not work or are not supported, you might expect some bugs. I will suggest you to raise a feedback via this form and submit your query on this page.

    259869-image.png

    Feedback.

    Hope this helps.
    JS

    ==
    Please Accept the answer if the information helped you. This will help us and others in the community as well.

    ==


  2. GitaraniSharma-MSFT 49,391 Reputation points Microsoft Employee
    2022-11-24T13:15:02.563+00:00

    Hello anonymous user ,

    Apologies for the delay in response.

    I understand that you are trying to configure and deploy Azure Virtual Network Manager but when you click the "Select scopes", it always times out.

    As mentioned in the Azure Virtual Network Manager document,

    During the creation process, you define the scope for what your Azure Virtual Network Manager will manage. Your Network Manager will only have the delegated access to apply configurations within this scope boundary. Defining a scope can be done directly on a list of subscriptions. However it's recommended to use management groups to define your scope. Management groups provide hierarchical organization to your subscriptions.

    So, make sure you have a management group created. If not, please create one.
    Refer: https://learn.microsoft.com/en-us/azure/governance/management-groups/create-management-group-portal

    Another issue could be that your subscription is not registered for Management Resource Provider.

    Could you please check if "Microsoft.Management" resource provider is registered under your subscription?
    If not registered, please register "Microsoft.Management" in your subscription and try again.
    Refer : https://learn.microsoft.com/en-us/azure/azure-resource-manager/management/resource-providers-and-types#azure-portal

    263943-image.png

    Kindly let us know if the above helps or you need further assistance on this issue.

    ----------------------------------------------------------------------------------------------------------------

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments

  3. Ed Oatley 1 Reputation point
    2022-11-24T13:52:03.457+00:00

    Hi @GitaraniSharma-MSFT

    Thank you for the response, I checked both of the things mention and they looked good so I tried to create the Network Manager again just now via the portal and strangely it worked fine.

    Not very satisfying as it appears to have fixed itself with no action taken but at least I can achieve what I set out to now.

    Appreciate your help

    Ed