Azure Arc Resource Bridge (Azure Stack HCI)

Aric Bernard 11 Reputation points
2022-11-13T23:48:38.417+00:00

I want to deploy the Azure Arc Resource Bridge for Azure Stack HCI into a simple lab using robust "validated node" hardware. I have evaluated all requirements and pre-requisites to ensure compliance of my environment. I've attempted deployment using both Windows Admin Center as well as via PowerShell half a dozen times each using a variety of different parameters; however in all attempts deployment fails.

PowerShell attempts result in:

ERROR: {
"errorCode": "DeployKvaTimeoutError",
"errorResponse": "{\n\"message\": \"Appliance Deploy timed out\"\n}"
}
INFO: Command ran in 1805.989 seconds (init: 0.724, invoke: 1805.265)

Windows Admin Center deployments result in:

Error: Install-ResourceBridge: C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2\wbin\az.cmd arcappliance deploy hci --config-file "C:\ClusterStorage\Volume01\ResourceBridge\hci-appliance.yaml" --outfile "C:\Users\Administrator.HCSC.kube\config" returned a non zero exit code 1 [] Please check your system and retry deployment.

The environment is using a single very large (/16) subnet and there is no proxy server in play.

The C:\Users\Administrator.HCSC.kube\config file contains only the following:

null
...

I can find no other logs to assist in diagnosing the issue. My experience so far does not instill confidence. Looking for suggestions.

Azure Stack HCI
Azure Stack HCI
A hyperconverged infrastructure operating system delivered as an Azure service that provides security, performance, and feature updates.
309 questions
{count} vote

4 answers

Sort by: Most helpful
  1. CyrAz 5,181 Reputation points
    2022-11-14T14:08:38.433+00:00

    Did you have a look at that KB and verified everything it mentions was OK?
    https://learn.microsoft.com/en-us/azure/azure-arc/resource-bridge/troubleshoot-resource-bridge#kva-timeout-error


  2. vipullag-MSFT 25,941 Reputation points
    2022-11-15T18:20:17.043+00:00

    @Aric Bernard

    Welcome to Microsoft Q&A Platform, thanks for posting your query here.

    Based on the details shared, looks like the a configuration mistake.
    Regardless of that, can you try revise the settings and check the network configuration and the Ips supplied. In most ARC cases, these values are misconfigured in the environment.

    Hope this helps.
    If you need further help on this, tag me in a comment.
    If the suggested response helped you resolve your issue, please 'Accept as answer', so that it can help others in the community looking for help on similar topics.


  3. Jesper M. Christensen 1 Reputation point
    2022-12-06T10:38:28.943+00:00

    Where you able to resolve the issue please?

    I have installed 4 sites x 2 Azure Stack HCI nodes with the same PowerShell script only changing IP addresses and servernames.

    Now I get the same error and tried various updates and checks of network configuration.


  4. Carlos M 0 Reputation points
    2023-02-27T16:29:20.3466667+00:00

    Hi, I have exactly the same issue. Any suggestion about that?

    I have tried this from WAC too using 'static IP (recommended)' and 'DHCP' options with VLAN and without it and its still failing...

    Network configuration is the same type as @Aric Bernard is only a lab environment with no proxies and no additional firewall rules...

    I think it's maybe a Windows Admin Center bug. Anyways if there is a solution, please let me know.

    Thanks, regards.