Updating a csproj based standard logic app to use Workflows.WebJobs.Extension causes an error in Azure

John Bosch 36 Reputation points

I have a Standard Logic App that has a custom built-in connector and is built as a csproj based project. I have just updated the logic app to use Workflows.WebJobs.Extension version and, while I can debug the logic app locally though VS Code, it fails to run in Azure with the error "System.Private.CoreLib: Could not find file 'C:\home\site\wwwroot\NetFxWorker\cs'.".

The same result happens regardless of whether I use the current v3 runtime with .net Core 3.1, or the v4 runtime with .net 6.0.

Any ideas?

Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,102 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Manoj Kumar 0 Reputation points

    Hi @Palak Chadha .
    I am getting the same error while deploying it. Can you please update how it was resolved.


    0 comments No comments