Share via

Logic apps - condition not working

Georgi Palazov 286 Reputation points
2022-11-16T12:34:07.37+00:00

Hello,

What i'm trying to do is when an incident is triggered->check with query if its related to OracleDBAudit table. If not - don't send email. If yes - send email.
Below you can find the logic app flow i'm trying to implement:

260963-image.png

Run query and list results contains:

SecurityAlert
| where AlertName contains "OracleDBAudit"
| where IsIncident == true

  • In my case this is returning no results when inserted in LOGS, thus send no email. However I get an email no matter what.

260899-image.png

Below you can find the output from the Run query and list results which returns nothing and still the condition is TRUE?

260983-image.png

Azure Logic Apps
Azure Logic Apps

An Azure service that automates the access and use of data across clouds without writing code.

Microsoft Security | Microsoft Sentinel
0 comments No comments

Answer accepted by question author

David Broggy 6,801 Reputation points MVP
2022-11-16T14:43:59.693+00:00

Hi @Georgi Palazov ,

I don't think you can use a blank entry for your 'is not equal to'.
It must specify a 'null' value as a function.

Here's an excellent example:

how-to-deal-with-possible-null-values-in-control-c.html

261043-image.png

Was this answer helpful?

1 person found this answer helpful.
0 comments No comments

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.