Task View (Windows 10) - Desktop changes when opening Microsoft Excel

Robert Mathisen 21 Reputation points


In Windows 10, I have 2 Desktops open in Task View (Desktop 1 & Desktop 2)

I have Excel open in Desktop 1.
Then, I switch over to Desktop 2, and open Excel.

Doing this will automatically change me back over to Desktop 1.

How do I stop this from happening?

Thank you!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
7,511 questions
0 comments No comments
{count} votes

Accepted answer
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 19,141 Reputation points Microsoft Vendor


    If you do not want to switch back to the opened Excel window, you'll have to start a second Excel instance. Keep holding down the Alt key and click on the Excel icon on the taskbar or in the start menu, then you will see a prompt whether you want to start a new instance of Excel. Click yes and a new Excel window will appear on the current desktop.

    Best Regards,
    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

0 additional answers

Sort by: Most helpful