Unable to delete a Resource Group

Stas Levich 6 Reputation points

The error

Failed to delete resource group TPL: Deletion of resource group 'TPL' failed as resources with identifiers 'Microsoft.Web/serverFarms/TPL' could not be deleted. The provisioning state of the resource group will be rolled back. The tracking Id is '6d73a801-b9b8-4832-bc13-a7ce4e7d96ed'. Please check audit logs for more details. (Code: ResourceGroupDeletionBlocked) Server farm with name TPL not found. (Code: NotFound, Target: /subscriptions/e9xxxxx-26xxxxxxxxx95/resourceGroups/TPL/providers/Microsoft.Web/serverFarms/TPL)

The only resource the resource group shows it still has is a App Service plan, but when I click on it to try to delete it manually I get 404.


Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
4,925 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Rafael da Rocha 3,936 Reputation points

    Hello @Stas Levich ,
    this might be related to backend issues and should be fixed in a few hours.
    Have you tried the operation in a different browser or using "private browsing"?

    Here's a link to a similar situation:

    0 comments No comments

  2. ajkuma 14,856 Reputation points Microsoft Employee

    StasLevich, Firstly, apologies for any inconvenience with this issue.

    If you haven’t tried this already, kindly see if the resource is visible via Resource Explorer and then try to delete it.

    Note: When you delete resources, the actions are irreversible. Kindly delete unwanted resources.

    1. Navigate to https://resources.azure.com/
    2. Make sure you are in the Read/Write mode
    3. Navigate to the parent resource group (RG) of the App Service Plan (ASP) (or search for the App) || try to delete RG or ASP/app
    4. Navigate to the provider -> Microsoft.Web
    5. Navigate to sites
    6. Navigate to the problem site/app*.
    7. Click on the Action/Delete
    8. Click on the Delete button to delete the problem site/app*

    Resource Explorer

    Kindly let us know how it goes, I'll follow-up with you further. Thanks for your patience!

    0 comments No comments

  3. Stas Levich 6 Reputation points

    Thanks guys, I was able to finally delete the group...somehow.