Deploy the ARM template to the newly created Azure Resource Group

An Nguyen Thuan 21 Reputation points

Hello, I'm new to Azure Digital Twins,

I'm learning course "Connect IoT data to mixed reality with Azure Digital Twin and Unity", I follow every step but come to this step "Deploy the ARM template to the newly created Azure Resource Group" I got error:

ERROR: {"code": "InvalidTemplate", "message": "Deployment template validation failed: 'The template resource '' of type 'Microsoft.Authorization/roleAssignments' at line '344' and column '5' is not valid. The name property cannot be null or empty. Please see for usage details.'.", "additionalInfo": [{"type": "TemplateViolation", "info": {"lineNumber": 344, "linePosition": 5, "path": "properties.template.resources[17]"}}]}

I downloaded template from the link Githup attach to the course, I can't find the way to fix it, can someone help me.

Thanks and sorry about my bad English.

Azure Digital Twins
Azure Digital Twins
An Azure platform that is used to create digital representations of real-world things, places, business processes, and people.
153 questions
0 comments No comments
{count} votes

Accepted answer
  1. chbeier 1,861 Reputation points

    Hello @An Nguyen Thuan ,

    When I followed the instructions in ARM-Template README on github, the objectId and userId were zero. I changed the queries to

    $objectid=$(az ad sp list --display-name ${appreg} --query [0].id --output tsv)  
    $userid=$(az ad signed-in-user show --query id -o tsv)  

    When I first start the deployment as described in ARM-Template - Step 6 deploy, I got the same error as you. It is important that the parameters are set. So, check if userId and objectId are set correctly.


    If your issue was solved, please hit "accept answer" and feel free to rate up the post. This will help others with the same questions. Thanks

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful