Connecting to a remote computer using RDP does not work after I enable MFA

Stefan Baens 1 Reputation point
2022-11-23T10:40:46.89+00:00

We use microsoft Intune and have set up multiple users and computers with it.
There is sometimes the need of accessing a computer at the office from home, for this we have a dedicated VPN and use a RDP connection.
This works fine with credentials like AzureAD\user@keyman .
Only after I enable MFA for that user the RDP connection is not possible anymore, no question is asked for MFA either.
Logging on to the computer is then only possible when you are sitting behind it phisically.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,391 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,569 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Cristian SPIRIDON 4,471 Reputation points
    2022-11-26T09:37:04.253+00:00

    Hi,

    If you want rdp to work with Azure accounts that have mfa enabled you need to create a CA policy and exclude Azure Windows VM Sign-In app from MFA.

    More details on:
    https://learn.microsoft.com/en-us/azure/active-directory/devices/howto-vm-sign-in-azure-ad-windows#mfa-sign-in-method-required

    But there are also some other ways to have strong authentication with windows logon.

    Hope this helps!

    0 comments No comments