SQL Server Express 2019 Property DefaultFullTextLanguageLcid is not available for Database

Ian Hannah 21 Reputation points
2022-11-24T12:31:11.52+00:00

We have installed SQL Server 2019 Express (version 15.0.2000.5 which we believe is the latest version).

We have 3 databases. When we right click on any of them to look at the properties we get the following error:

Property DefaultFullTextLanguageLcid is not available for Database '[PPGallium_AuditJournal]'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

263951-image.png

However, If we run a simple C# application that simply connects to the database then the access to the properties works as expected. This is the code of the simple application:

        SqlConnection connection1 = new SqlConnection(ConsoleApp13.Properties.Settings1.Default.MetadataDatabaseConnectionString);  
        SqlConnection connection2 = new SqlConnection(ConsoleApp13.Properties.Settings1.Default.ScheduleDatabaseConnectionString);  
        SqlConnection connection3 = new SqlConnection(ConsoleApp13.Properties.Settings1.Default.AuditDatabaseConnectionString);  

        connection1.Open();  
        connection2.Open();  
        connection3.Open();  

        Console.WriteLine("Connections all made. Press any key to continue...");  
          
        Console.ReadLine();  

While the connections are open, access to the properties is possible. As soon as the simple application is closed down, the error message appears when the properties of any of the databases is accessed.

Please note that this issue does NOT happen with SQL Server 2019 Standard Edition i.e. the properties of the databases can be accessed without the need to run a separate application.

Does anyone have any ideas on what the issue is?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,296 questions
0 comments No comments
{count} votes

Accepted answer
  1. Seeya Xi-MSFT 16,461 Reputation points
    2022-11-25T02:19:25.44+00:00

    Hi @Ian Hannah ,

    This seems to be a permission issue. You can quickly resolve this issue by running following command in your query window.

    USE YourDBName  
    GO  
    sp_changedbowner 'sa'  
    GO  
    

    DefaultFullTextLanguageLcid is a setting in the database Properties. If the above does not work, you can reconfigure this option:
    Configure the default full-text language Server Configuration Option
    Here is a sample script:

    USE AdventureWorks2012 ;    
    GO    
    EXEC sp_configure 'show advanced options', 1 ;    
    GO    
    RECONFIGURE    
    GO    
    EXEC sp_configure 'default full-text language', 1043 ;  --You need choose your language: Values Returned for Default Languages. (The link is at the end)  
      
    GO    
    RECONFIGURE    
    GO  
    

    Values Returned for Default Languages

    Best regards,
    Seeya


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Bjoern Peters 8,856 Reputation points
    2022-11-24T13:18:56.287+00:00

    Hi @Ian Hannah

    Just for your belief in "latest version" ;-)

    The latest version (also for an Express Edition) is 15.0.4261.1

    263936-image.png
    https://sqlserverbuilds.blogspot.com/#sql2019x

    If this fixes your problem... I don't know, but maybe...

    0 comments No comments

  2. Ian Hannah 21 Reputation points
    2022-11-24T13:55:27.837+00:00

    I upgraded to SQL Server 2019 CU 18 (Version 15.0.4261.1) and the problem still occurs. Thanks for the suggestion - I hadn't thought of checking the CU updates.

    0 comments No comments

  3. Ian Hannah 21 Reputation points
    2022-11-27T13:44:30.233+00:00

    Thank you! It was indeed a permissions issue. This worked:

    USE YourDBName
    GO
    sp_changedbowner 'sa'
    GO

    0 comments No comments