Hello @Vaishali Ramchandran ,
Thank you for reaching out to the Microsoft Q&A platform. Happy to answer your question.
As far as I know, and the documentation is considered auto-scale feature is supported on Free/Trial subscriptions as well. In order to test this scenario, I have set up a free trial and reproduced the error successfully
Cause:
As this error doesn't give any clues or reasons for failure. I have enabled network traces on the browser(Developer tools option in browser) and looked at the network trace logs, and found that the reason of failure is that it needs "Microsoft.Insights" resource provider to be registered on the subscription.
Sinppet from network traces:
extension: Microsoft_Azure_Monitoring
{"error":{"code":"MissingSubscriptionRegistration","message":"The subscription is not registered to use namespace 'microsoft.insights'. See https://aka.ms/rps-not-found for how to register
Solution:
I have checked and registered the 'microsoft.insights' provider from ->Subscriptions->Resource Providers blade->microsoft.insights as it was not registered.
Once it got registered, I was able to set the auto-scale with custom configuration as you can see in the below screenshot
Hope this helps!
Please "Accept as Answer" and Upvote if the answer provided is useful, so that you can help others in the community looking for remediation for similar issues.