Server 2012 R2 certificate shows incorrect password, but will install with password in Windows 10

Gregg Hughes 291 Reputation points
2022-11-29T22:34:38.237+00:00

Good afternoon, all!

I'm having a problem importing a PFX cert into a Server 2012 R2 machine. When I do the import it errors out on the password. However, if I try the installation with my Win 10 laptop, the password succeeds with no problem. It looks like the cert is valid, but someting in the 2012 R2 server is either broken or missing.

The cert is from GoDaddy and I'm building the .pfx using OpenSSL on Windows. Again, the cert seems to be fine as the password works either typed or copy/paste.

Has anyone run into this before or have any thoughts on why this might be happening?

Thanks to all for looking!

Gregg

UPDATE - I tried using Win64 OpenSSL 1.1.1s but with no success. Any ideas on possible variables to use building a CSR and PFX?

Thanks!

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,565 questions
Windows Server Security
Windows Server Security
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
1,776 questions
{count} votes

Accepted answer
  1. Limitless Technology 44,096 Reputation points
    2022-12-02T12:48:54.063+00:00

    Hi,

    Thank you for posting your query.

    Kindly follow the steps provided below to resolve your issue.

    Import the .pfx into a newer version of Windows (Like Windows 10 or 2016) . This is important. While you import process, mark the certificate as exportable. This allows you to export the certificate afterwards with the older Triple-DES-SHA1 algorithm or/and with no password to protect the key.

    Go to this link for your reference and other troubleshooting procedures https://learn.microsoft.com/answers/questions/995232/password-incorrect-when-import-certificate-on-serv.html

    ----------------------------------------------------------------------------------------------------------------

    If the answer is helpful kindly click "Accept as Answer" and up vote it.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Daisy Zhou 20,876 Reputation points Microsoft Vendor
    2022-11-30T03:26:41.123+00:00

    Hello GreggHughes-3883,

    Thank you for posting in our Q&A forum.

    The information in the similar threads seem to be able to explain the issue you mentioned.

    And you can try the method (command) in the threads to import the certificate on Server 2012 R2.

    "The password you entered is incorrect" when importing .pfx files to Windows certificate store
    https://stackoverflow.com/questions/69343254/the-password-you-entered-is-incorrect-when-importing-pfx-files-to-windows-cer

    Windows certificate import not accepting private key password
    https://serverfault.com/questions/1097326/windows-certificate-import-not-accepting-private-key-password

    Hope the information above is helpful.

    Best Regards,
    Daisy Zhou

    ===============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  2. Gregg Hughes 291 Reputation points
    2022-12-06T13:21:14.323+00:00

    Good morning!

    Building the .pfx and importing into Windows 10, then exporting with the private key and importing into Server 2012 R2 worked and the new cert is functioning.

    Thanks to all!

    G

    0 comments No comments