local drivers in remoteApp

remoteUser1 101 Reputation points
2020-09-30T00:33:48.877+00:00

Hello,

I enabled Drivers in local settings as shown in the link below.
https://social.technet.microsoft.com/Forums/en-US/10443f70-c56d-42e4-b8ac-f2f8c0c3a975/redirecting-usb-drives-and-local-drives-to-rds-collection-desktop?forum=winserverTS

however, I am still unable to see my local drivers when I launch wordpad, and clicked "save as..." from remoteApp.

how to enable the local drivers for remoteApp in windows 2019? thanks

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,065 questions
No comments
{count} votes

Accepted answer
  1. Jenny Yan-MSFT 9,206 Reputation points
    2020-10-01T07:44:23.137+00:00

    Hi,

    I am afraid if this is the limitation of RD web client cause there is feature request to add drive redirection for RDC of web in the user voice forum.

    You could either post your feedback here or vote the similar thread.
    https://remotedesktop.uservoice.com/forums/911494-remote-desktop-client-for-web?query=drive

    Hope this helps and please help to accept as Answer if the response is useful.

    Thanks,
    Jenny

    No comments

2 additional answers

Sort by: Most helpful
  1. Jenny Yan-MSFT 9,206 Reputation points
    2020-10-01T03:40:09.727+00:00

    Hi,
    In the link you shared, it mentioned to configure drive redirection through mstsc tool and also use powershell command to redirect USB drives and local drives to RDS collection desktop.

    Did you make all the changes mentioned?

    Moreover, have you tried to remote to the session host server directly and open the remoteapp that published?

    Pleas also check the GPO below in the session host server:
    *Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection
    ****Do not allow drive redirection*----> disable****

    Hope this helps and please help to accept as Answer if the response is useful.

    Thanks,
    Jenny

    No comments

  2. remoteUser1 101 Reputation points
    2020-10-01T03:49:40.34+00:00

    Hi Jenny,

    thanks so much for the help.

    the GPO setting is done and it still doesn't work.
    right now, https://myhostname.com/RDWeb/ works fine with the local disk mounted when logging.
    however, https://myhostname.com/RDWeb/webclient doesn't work after the login.

    No comments