Intune Kiosk Blue Screen Spinner / After UWP App Restart or Update

asked 2020-10-01T13:22:02.487+00:00
Leigh 26 Reputation points

We're utilising Windows 10 LTSC IoT Enterprise 2019 to deploy a UWP (Sideloaded via Intune) kiosk app for a self-serve PoS, and facing a number of issues with the uptime of our devices.

Our kiosk profile is fully setup and configured via Microsoft Intune, we have a number of provisioned devices deployed into production environments, however all of them face random blue screen issues when the app crashes, restarts or updates.

I have spent three days this week attempt to try to identify the cause, however nothing seems obvious. There are a number of random errors that do show in the AppXDeployment-Server Event Viewer logs:

  • error 0x80070005: Opening file from location: TESTBLUESCREENAPP_1.0.1.0_neutral_~_d705ytxceh5t2.xml failed with error: Access is denied.
  • The check for how TESTBLUESCREENAPP_1.0.1.0_neutral_~_d705ytxceh5t2 applies to user S-1-12-1-3773057833-1191388284-959488690-126330809 failed with Access is denied..
  • Determining packages to be installed during logon for user: S-1-5-21-3112998706-1580087439-4190299968-1001.

And in the case of when our app updates we also sometimes see this:

  • error 0x80070057: Unable to relaunch app TESTBLUESCREENAPP__d705ytxceh5t2!App after the app was serviced.

I have this week tested this with a standard out of the box UWP app targeting Build 17763, with just a view, and two buttons; one to update the app and one to restart the app. The app is deployed and working until we press one of the buttons. The update function utilises a nuget package running on BG task (Dwrandaz
/ AutoUpdateComponent
)

Here's our app in Assigned Access mode provisioned via Intune:
29626-image.png

The restart app button makes a call to the API CoreApplication.RequestRestartAsync.
When invoking this call in the app in Assigned Access / Kiosk mode, the app always closes, but sometimes it relaunches and sometimes it does not. When the app fails to relaunch, we see only a blue screen with a windows Progress Ring shown:29617-stuck.jpg

When we see this screen, no events are written to the event viewer. The computer simply hangs on this screen forever or until a Ctrl+Alt+Del is sent and the PC has to be fully restarted!

There seems to be no obvious cause, but I do notice other people facing the same issue:

  1. https://learn.microsoft.com/en-us/answers/questions/25947/uwp-problem-when-restart-app-on-kiosk-mode.html
  2. https://github.com/Dwrandaz/AutoUpdateComponent/issues/2
  3. https://answers.microsoft.com/en-us/windows/forum/all/windows-assigned-access-gets-stuck-at-bluescreen/166c0f8b-a8a1-4abc-ab61-4817667f4419?auth=1

When we push the Update button, the app always updates to the next version. Then, sometimes it reloads as expected, and sometimes it does not. When it does not, we see the app logo initially:
29684-image.png

Then followed by a blue screen like this after maybe 60 seconds:
29585-image.png

And again the only way to exit this is to send Ctrl+Alt+Del, but this time the PC does not need to be reset, it will login to the Kiosk account again and the app with show with the new version installed.

As you can imagine this does not look good on a kiosk in the middle of an airport for example! The inconsistency of restarting the app and updating the app is a big problem.

Can anybody point me to any possible answers?

Windows 10 IoT Core
Windows 10 IoT Core
An Azure subscription offering that provides the essential services needed to commercialize a device on Windows 10 IoT Core.
231 questions
{count} votes

2 answers

Sort by: Most helpful
  1. answered 2020-11-20T13:58:16.847+00:00
    Andreas 6 Reputation points

    First of all I must say to Microsoft developers that you really have made the whole appinstallation procedure combined with Kiosk mode really frustratingly complicated!!! I have now worked two full days and there are many ways to mess this up but not many to succeed!

    But anyway I finally made this work 🎉✨🏆

    So the first thing you can´t do:
    Add a new account with the + below. Install the app for this user and then setup assigned access for this account. If you do this you will get the Blue-screen spinner problem everytime you try to update like mentioned above.

    41493-adduser.png

    My guess is that something have happened in some windows update with the sideloading of apps to non administrator accounts or something like that? Because I know that I have installed my sideloaded app to a local account earlier, and then made this account into an assigned access account. But this is no longer possible. Now I need to make the second account administrator first in order to be able to install the app. Then I need to make it to a not administrator account again in order to make it assigned access. If I do this, the app works under assigned access, but I cant use the update function like described above.

    So now to what actually works in my case
    Install the app you want to use on your admin account.
    Do not add a local account. Instead directly under "Set up a kiosk" click "Assigned access".
    Don´t use an existing account. Click get started and add a new name for the kiosk account you want and add the app for this account.
    Done.
    When I restart with this new Assigned Access account the update function works and it does not get stuck in blue screen.
    Edit: To clarify. It also works to update from within the assigned acces account when created this way. For me at least. But I don´t know if this is just good luck.

    The difference between theese two ways of creating an assigned access account is something some windows developer gladly could help me understand.
    The disadvantage of creating an assigned access account the new way for me is that it is hard to make changes to the assigned access account. For instance on my old account where I first created the account I could change the tablet mode setting easily before setting the account as assigned access. Now I have still not figured out how to change this. Changeing in my administrator account makes no difference :(

    @Leigh have you managed to get this to work yet? It would be interesting to heare if this works for you as well or if you have done something different.


  2. answered 2020-11-27T11:32:54.303+00:00
    Arnt-Hugo Nilsen 1 Reputation point

    Had the same problem with Kiosk being stuck at the blue screen trying to log on. This was a single app kiosk using only EdgeHTML. Found that the kiosk was updated to Edge Chromium, which is not supported. So now we have blocked the kiosk at win10 2004 for now, so it doesnt update to Edge Chromium. the kiosk now works, but this is of course just temporary solution while waiting for support for Edge Chromium

    No comments