Block connection of an email address in Office 365 hybrid mode

Mohamed Ali ABIDI 161 Reputation points


We use Office 365 in hybrid mode.

We want to block connections to certain email addresses from only the Office 365 tenant and keeping the corresponding user account active in Microsoft Active Directory.

But when we block the connection of an email address in the Office 365 tenant it does not work, the connection to the address is reactivated after each synchronization of AD connect since the user account has remained active in the Microsoft Active Directory.

Is there a permanent solution to permanently block the connection from the Office 365 tenant without deactivating the user account in the Microsoft Active Directory.


Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,238 questions
Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,684 questions
No comments
{count} votes

Accepted answer
  1. Andy David - MVP 109.8K Reputation points Microsoft MVP

    Not possible since you are syncing from on-prem to Azure.
    You could however create a conditional access policy that blocks access to all apps for those accounts. They would still be able to authenticate, they just would not be able to access any application in Azure/365.

    No comments

1 additional answer

Sort by: Most helpful
  1. Jame Xu-MSFT 2,926 Reputation points Microsoft Employee

    Hi @Mohamed Ali ABIDI ,
    Agree with Andy, you could set the conditional access policy in the Azure AD. You could refer to: Conditional Access: Block access

    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments