SharePoint 2019 Search is broken after configuring SSL

Manveer Singh 1 Reputation point
2020-10-02T15:02:02.97+00:00

Hi,

We have implemented SSL and redirecting http to https based on below scenario.

1) Default Zone URL: http://servername:10101, we extended this to intranet zone with https://servername.projects.com:10105 and updated the bindings in IIS. Sites are working fine with SSL URL.

2) In IIS for http://servername:10101 we have created URL redirect to https://servername.projects.com:10105 so that users will be redirected to SSL URL for old links. Redirects are working perfect.

When we are trying to search anything in https://servername.projects.com:10105 is not showing any result and no error in ULS.
We have tried enabling NO SSL Warning in search service application and also tried with SSL Urls in contents source but no luck.
We have restarted all search related services but no luck. We can see crawled contents from SSL URL in Crawl Log- URL.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,151 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,763 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Emily Du-MSFT 39,366 Reputation points Microsoft Vendor
    2020-10-05T08:57:55.317+00:00

    @Manveer Singh

    In the SharePoint search, query processing component queries contents with the default zone URL.

    Go to central administration -> Search service application -> Content source, check whether the default zone URL, then do a full crawl.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. sadomovalex 3,621 Reputation points
    2020-10-07T15:56:27.037+00:00

    try to make it vise versa: use SSL for default zone (you will need to change AAM and IIS site binding for that) and http for extended zone. Crawler should crawl default SSL zone. Check similar question here: SharePoint 2013 Search Service Not Crawling SSL (https) web application.

    0 comments No comments

  3. sco gordo 301 Reputation points
    2020-10-07T17:56:20.317+00:00

    Check the new https URL from all of your FE and APP servers. If you can't, for example, hit it from your APP server, you may have host file entries for the http address but not https. Add the https entry and should be good.

    0 comments No comments

  4. Lecia 1 Reputation point
    2022-09-09T09:54:28.137+00:00

    I am having the same issue, when Im on https my search is not working.

    0 comments No comments