Unable to open the excel file in client application from the Link Webpart

SR VSP 1,221 Reputation points
2020-10-02T21:15:18.63+00:00

Hi Guys,

We have a SharePoint Online site collection that has the Open in Client Application both enabled in Site Settings and on the document library itself.On one of the modern site page the Link/Doc library.. view web part is used to display the content of the document libraries. If the end user clicks on a document on this page - it will default to open in the browser and not in the client application.

Any ideas on why this might be happening?

Please find attached snapshot for reference

29874-link-webpart.jpg

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,210 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,765 questions
{count} votes

2 answers

Sort by: Most helpful
  1. JoyZ 18,031 Reputation points
    2020-10-05T06:21:31.91+00:00

    Hi @SR VSP ,

    If you are using link web part to display document in modern page, please use direct link instesad of sharing link, such as:

    https://tenant/sites/site/Document/Book.xlsx

    Per my test, when click the preview of the file, it will pop up a box to open the file in client(same result in Document library web part):

    30102-image.png

    Here is an article about how to get direct link to a document in modern libraries for your reference:

    https://www.sharepointdiary.com/2018/06/sharepoint-online-get-direct-link-to-document.html


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. JoyZ 18,031 Reputation points
    2020-10-06T02:22:52.1+00:00

    Hi @SR VSP ,

    In order to get a better forum experience, we changed your answer to a comment.

    Per my test I use the “Link” web part, not the “Quick links” web part.

    30264-image.png 30304-image.png

    For the “Quick links” web part, the setting to open the file in the client does not work, for more detail information, please refer to

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_sharepoint-mso_win10-mso_o365b/sharepoint-online-quick-links-open-item-behavior/6eccc383-c992-4dfe-978c-da856110e9c3

    As a workaround, it's suggested to add "Document library" web part directly or use "Link" web part to open file in office client.