Unexplained Error While Building Docker Container

Derrick Lichti 1 Reputation point
2023-01-07T06:32:42.46+00:00

Despite having been running successfully for two years, our pipeline ceased working with this error message:

The command '/bin/sh -c /bin/bash -c 'chmod +x ./.az/docker/script.sh'' returned a non-zero code: 1
The process '/usr/bin/docker' failed with exit code 1

when attempting to run:
RUN /bin/bash -c 'chmod +x ./.az/docker/script.sh'

We've been running for ~two years using updated versions of the slim (now at python:3.9.15-slim). The does exist. No updates to this container or pipeline for several weeks, with many successful builds. Access to our ACR and source code repos is functioning well. We've tried various runners, all terminating with the same error.

Hoping to hear of a related resolution to get our pipelines running again (36+hrs and counting).

2023-01-07T05:28:10.5489107Z ##[section]Starting: Initialize job
2023-01-07T05:28:10.5491049Z Agent name: 'Hosted Agent'
2023-01-07T05:28:10.5491693Z Agent machine name: 'fv-az165-419'
2023-01-07T05:28:10.5491979Z Current agent version: '2.213.2'
2023-01-07T05:28:10.5538738Z ##[group]Operating System
2023-01-07T05:28:10.5539453Z Ubuntu
2023-01-07T05:28:10.5539647Z 22.04.1
2023-01-07T05:28:10.5539818Z LTS
2023-01-07T05:28:10.5540102Z ##[endgroup]
2023-01-07T05:28:10.5540309Z ##[group]Runner Image
2023-01-07T05:28:10.5540604Z Image: ubuntu-22.04
2023-01-07T05:28:10.5540826Z Version: 20221212.1
2023-01-07T05:28:10.5541295Z Included Software: https://github.com/actions/runner-images/blob/ubuntu22/20221212.1/images/linux/Ubuntu2204-Readme.md
2023-01-07T05:28:10.5541852Z Image Release: https://github.com/actions/runner-images/releases/tag/ubuntu22%2F20221212.1
2023-01-07T05:28:10.5542396Z ##[endgroup]
2023-01-07T05:28:10.5542679Z ##[group]Runner Image Provisioner
2023-01-07T05:28:10.5542949Z 2.0.98.1
2023-01-07T05:28:10.5543132Z ##[endgroup]

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
23,970 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. deherman-MSFT 23,816 Reputation points Microsoft Employee
    2023-01-09T18:10:59.187+00:00

    Azure Devops is not currently supported here on Microsoft QnA.
    The Community Members and Engineers are actively answering questions in dedicated forums here. Please post your question in that forum:
    https://developercommunity.visualstudio.com/spaces/21/index.html
    https://azure.microsoft.com/en-in/support/devops/

    No comments