Does Linux GDB work on Azure Dpsv5 VMs (ARM64)?

Anonymous
2023-01-08T21:20:07.24+00:00

I cannot use Step or Next commands in GDB on an Azure Standard_D4pls_v5 VM running Ubuntu 22.04.

#include 
Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,611 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. srbhatta-MSFT 8,351 Reputation points Microsoft Employee
    2023-01-16T13:18:06.62+00:00

    Hello @Anonymous , Welcome to Microsoft QnA. It looks like the issue you're experiencing is related to a segmentation fault (SIGSEGV) that occurs when using the "next" (n) command in GDB. This is likely caused by a problem with the libthread_db library, which is used by GDB to access thread-specific information in the program being debugged.

    The link you provided to the cloud-hypervisor issue on GitHub is related to a similar problem that some users have experienced when using GDB with the cloud-hypervisor, which is a type-1 hypervisor that runs on ARM64 processors. However, it's unclear from the information you've provided whether this is the root cause of the problem you're experiencing on your Azure VM.

    It's possible that there is a bug in the version of GDB you are using, or in the libthread_db library. The best way to confirm this would be to try running the same program and GDB commands on a different ARM64 machine and see if the issue still occurs.

    Another potential solution is to try using a different version of GDB. I suggest you to check with Ubuntu if there is any version restriction for GDB with ARM64.

    You can try building the latest version of GDB from source, which may contain fixes for the issue you're experiencing. Also, you can try using another debugger like LLDB to see if it has the same problem.

    If the above suggestions don't help, I would recommend you to open a Azure Support case for this issue. Let me know if incase you do not have a support plan enabled on your subscription. Thank you.

    No comments