Storage Space partition unavailable after disk removal

Moro 41 Reputation points
2023-01-11T08:53:54.7333333+00:00
Hi,

on a Windows 10 latest version fully updated I have a Storage Pool composed by 13 drives in three 5 disks USB chassis and one in a single USB dock hosting a Virtual Disk with Dual Parity (10 columns, physical disk redundancy 2, 16Kb interleave) .

It worked perfectly until yesterday when I tried to physically move (with a computer shut down obviously) a drive from a single USB dock to a 5 disk storage. After the move the SP was displayed in the SP console however all disks flashed rapidly and the Z: drive (50TB, 128Kb clusters), the only partition that is on the SP, was not present anymore. Disk Management showed a strange situation where it could not see anymore the 50TB partition, instead showed what reported in the below image.



I immediately shut down again the computer and move back the hd from the 5disk storage to the single dock, powered up the computer and everything when up correctly.

Since I never had any other issue in moving all other disks, I decided to remove the involved disk through the SP standard procedure (Storage Space Console --> Prepare for removal).

This morning I checked the computer and Z: was disappeared and Disk Management showed again the situation reported in the above picture.

The Storage Space console shows me that everything works correctly and everything is at his place as yesterday, even the 50TB partition. Even the removing of the drive is still ongoing, disks seems to work to remove the drive and the amount of used space in the single USB dock drive that is lowering, also now that Z: is no more available and disk management cannot see the partition correctly.



Thanks for any help, right now I do not have access anymore to my SP partition!
Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
5,942 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Moro 41 Reputation points
    2023-01-11T08:58:18.79+00:00

    Capture

    No comments

  2. Moro 41 Reputation points
    2023-01-11T11:21:54.3366667+00:00

    Solved: a complete hardware shutdown solved the issue.

    No comments