can't deploy SSAS tabular with legacy connection

A B 21 Reputation points
2023-01-12T10:58:25.2433333+00:00

I'm creating a tabular model which contains some direct connection, and one legacy (table using this connection is a simple SQL Query)

when providing the username for impersonation (using a dedicated account that have access to databases), the validation works fine for all kind of datasources.

But when I deploy I receive an error message "Failed to save modifications to the server. Error returned: 'OLE DB or ODBC error: Login failed for user 'domain\specialaccount'.; 28000."

what is strange is that the same account works fine for the non-legacy datasource..

any idea ?

regards,

SQL Server Analysis Services
SQL Server Analysis Services
A Microsoft online analytical data engine used in decision support and business analytics, providing the analytical data for business reports and client applications such as Power BI, Excel, Reporting Services reports, and other data visualization tools.
999 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. A B 21 Reputation points
    2023-01-12T12:56:21.74+00:00

    Finally found the root cause. Using WITH sdfsd as (...) statement cause the deployment failure.

    even if I push the code to a view, same result..

    regards

    No comments

  2. PercyTang-MSFT 1,261 Reputation points Microsoft Employee
    2023-01-13T05:34:18.6466667+00:00

    Hi @A B

    I'm glad to see that you solved the problem, congratulations!

    Technology advances in encountering problems again and again and solving them.

    Best regards,

    Percy Tang


    If the answer is the right solution, please click "Accept Answer". If you have extra questions about this answer, please click "Comment".

    No comments