Hyper-V Core 2019 Administrator has no access rights to C:

David Scheele 1 Reputation point
2023-01-16T08:12:23.8133333+00:00

Hello,

about two years ago i set up a Windows Server 2019 Hyper-V Core. The server worked fine and we already host several VMs on it.

A month or two into using it, i noticed that the administrator did not have any access rights for the C: drive anymore. Whenever i tried to do something on C: directly, or system critical folders, even if it was just a command like "dir", I would get "Access Denied"

https://postimg.cc/Hr5f1nYT

sconfig also does not work, so I can't do any configuration on the system.

I have no idea what could have possibly caused this. Already tried a few things, everything i could find through google, but to no avail.

The admin has full reign on the connected D: RAID.

So far it worked fine for vm management, but I'd like to get full control back.

A reinstall would be a real pain, so I'm hoping there is another solution.

Any help would be apprechiated.

Some more screenshots (sorry that they are in german, I hope the relevant information is language independant):

https://postimg.cc/F7w263QP

https://postimg.cc/yJH21Kxc

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,824 questions
No comments
{count} votes