Microsoft Graph connector agent and .NET requirement

asked 2023-01-16T12:48:44.26+00:00
Michal Z. 141 Reputation points

Hi,

I am trying to install the Microsoft Graph connector agent and one of the prerequisites is

  • .NET Core Desktop Runtime 3.1 (x64)

When I click the link to this component I have the following information on the page:

This release has reached end of life, meaning it is no longer supported. We recommend moving to a supported release, such as .NET 7.0. See our support policy for more details.

As you are the .NET masters, can you tell me if I should install the old version or if I should follow the recommendation and install .NET 7.0?

.NET
.NET
Microsoft Technologies based on the .NET software framework.
598 questions
No comments
{count} votes

Accepted answer
  1. answered 2023-01-17T01:30:00+00:00
    Bruce (SqlWork.com) 27,936 Reputation points

    .net core versions run side by side. That means if an app requires .net core 3.1, it will not run on the current version. You must install the 3.1 version, which is out of support.

    if the app does not have a release for the current version, this suggests it is not receiving support or updates. You may want to pick a better supported product.

    No comments

1 additional answer

Sort by: Most helpful
  1. answered 2023-01-17T01:11:09.56+00:00
    Michal Z. 141 Reputation points

    I gave it a try on my lab environment.

    I have installed .NET 70 but the Microsoft Graph connector agent was still complaining.

    So I have installed the .NET Core Desktop Runtime 3.1 (x64) and the agent has installed without any problem \o/

    No comments