how to fix 00000003: LdapErr: DSID-0C060469, comment: Error decrypting ldap message, data 0, v1db1

R1prime 210 5 Reputation points
2023-01-16T17:51:33.78+00:00

Hello

We have a unique setup that has worked in the past but when trying to recreate it keeps failing

We have created an AD LDS/ADAM instance on a dedicated Win 2008 R2 server then created account using ADSI Edit in that instance that match the accounts in a web based application "maximo"

We can logon/bind with LDP with the account using port 636 with SSL and port 389

When we logon to maximo we get an error in the ADAM event log

Internal event: The LDAP server returned an error.

Additional Data

Error value:

00000003: LdapErr: DSID-0C060469, comment: Error decrypting ldap message, data 0, v1db1

I can't find a lot of info on what this error is.

Anybody else know what this error means?

Cheers

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
3,613 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. BOURBITA Thameur 11,551 Reputation points Microsoft MVP
    2023-01-16T18:18:27.72+00:00

    Hi,

    It seems a certificate problem.

    Check if root certificate is installed correctly on the server.

    Please don't forget to mark helpful reply as answer


  2. compdigit44 346 Reputation points
    2023-01-18T16:38:59.2466667+00:00

    Have you tried logging in with the non-secure LDAP port just for testing purposes?


  3. compdigit44 346 Reputation points
    2023-01-18T18:10:49.6033333+00:00

    In that case if does sound like a cert issue like R1prime 210 mentioned. What type of cert are you using? Local , 3rd party etc.... if local which CA template was used to create it?


  4. compdigit44 346 Reputation points
    2023-01-18T20:00:11.1133333+00:00

    Sorry for giving the shout out to the wrong user..... my mistake

    Hey compdigit44 it was @BOURBITA Thameur that suggested that it was a cert issue.

    Certs are issued from a 3rd party "entrust" and use a private key