MDT new regenerated image failed with 0xc0000098 iaStorAfs.sys

Eaven HUANG 2,101 Reputation points
2023-01-17T09:07:33.5466667+00:00

Dear Experts,

Out of sudden, I found that any new boot image we generated from MDT, then added into WDS always failed with 0xc0000098 iaStorAfs.sys. I've tried to use all drivers and package as selection profile in WINPE x64 properties, but still the same issue, I tried to deploy for HP probook and also DELL workstation, after loading the WDS image, it failed the same result.

Any help would be really appreciated.

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
794 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. TrudaZeng-MSFT 766 Reputation points
    2023-01-18T02:35:24.98+00:00

    Hi @Eaven HUANG ,

    IaStorAfs.sys is part of Intel Rapid Storage Technology. It’s usually an indicator that a kernel-mode driver attempted to access a pageable memory at an IRQL process that was too high.

    Try adding Intel Rapid Storage technology drivers to MDT PE. Refer to the following link in "Way 2. Update the Intel Rapid Storage Technology Drivers" section: https://www.minitool.com/news/iastora-sys.html

    --please don't forget to upvote and Accept as answer if the reply is helpful--