number matching MFA not working on iPhones

petersonal 86 Reputation points


We turned on number matching MFA in our tenant for ALL users, with all features (number matching, geographic location). For Android devices everything works fine. However for iPhones the new number matching not showing. They are getting the old push notification nothing else, the applications are up to date.

How could I troubleshoot this?


Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
5,086 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
18,609 questions
{count} votes

Accepted answer
  1. Andy David - MVP 137.9K Reputation points MVP

    Ok, that matches what I have.

    I think at this point, you have two options.

    1. Disable off, save and re-enable again
    2. Open a ticket with Azure support :(
    1 person found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Andy David - MVP 137.9K Reputation points MVP

    I found that once enabled, it took awhile, sometimes days later before it started working.

    Also ensure they are all running the latest Authenticator app version! :)

  2. Andy David - MVP 137.9K Reputation points MVP

    Interesting. Can you post an image of how its setup in the portal?

    You probably already know that the feature will be enabled for everyone automatically in a month regardless


    0 comments No comments

  3. petersonal 86 Reputation points

    Yes I know, but we would like to test it in our tenant first, and get some experience, and share with the clients what will change. Also there no opt out, and if I remember correctly the old version will not work. Correct me if I wrong.

    The settings are enabled through the portal I am attaching 3 pictures. If you need any more information please let me know.picture1



    0 comments No comments