SQLAzure is not available for your selection of subscription and location

Gary Frewin 25 Reputation points
2023-01-22T08:33:29.6833333+00:00

Hi Folks,

Trying to use Azure for the first time, I'm using a normal account (i.e not free tier or student) but it is just for a hobby project. I'm following the tutorial here in order to deploy my EFCore webapi project.

https://learn.microsoft.com/en-us/azure/app-service/tutorial-dotnetcore-sqldb-app

I'm on the page for Create WebApp + Database. I've slected my subscription and resource group and area UKSouth. When I select the database engine of SQLAzure, I get a the message in the topic name.

What is going on? I can select Postgres but I don't want or need that. I cannot select MySQL, and also, no matter what region I select the message is the same. It's also the same no matter whether I sleect basic or standard for the hosting plan.

I just want a simple web app with a sql database... what am I missing?

Thanks.

Entity Framework Core
Entity Framework Core
A lightweight, extensible, open-source, and cross-platform version of the Entity Framework data access technology.
702 questions
ASP.NET Core
ASP.NET Core
A set of technologies in the .NET Framework for building web applications and XML web services.
4,239 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Simon Alther 25 Reputation points
    2023-02-25T12:58:20.8666667+00:00

    I had to add (Register) Microsoft.Sql to the Resource providers of the Subscription (see screenshot below), then starting with the tutorial https://learn.microsoft.com/en-us/azure/app-service/tutorial-dotnetcore-sqldb-app worked for me.

    User's image

    5 people found this answer helpful.

  2. Gary Frewin 25 Reputation points
    2023-01-22T22:03:36.68+00:00

    Thanks, for the answers. The subscription was one that had been upgraded from a free credit one. However, I created a brand new subscription and I'm still getting the same result:
    User's image

    EDIT:

    Oddly, I switched back to the original subscription after doing this, and it now seems to be working...

    1 person found this answer helpful.

  3. Sadik Tas 75 Reputation points
    2023-01-22T19:14:22.7866667+00:00

    Please send your configuration page as follows:A screenshot showing how to configure a new app and database in the Web App + Database wizard.

    0 comments No comments

  4. Alberto Morillo 32,996 Reputation points MVP
    2023-01-22T19:40:44.6966667+00:00

    Maybe you created the new Azure subscription that enjoys a USD$250.00 free credit that later is upgraded to a pay-as-you-go subscription. In that scenario the error appears when you attempt to create an Azure SQL because of capacity issues on Azure.

    As a workaround, create another pay-as-you-go subscription in the same account and you will be able to create an Azure SQL database in the new subscription without any issues. After that you can delete the first subscription from your account, but you may lose the free credit associated with the first subscription.

    0 comments No comments

  5. Joshua Davies 1 Reputation point
    2023-01-24T04:45:49.5733333+00:00

    I am having the same issue. I have tried creating whole new accounts and am not yet able to fix the problem. I am creating pay-as-you-go accounts and attempting to create an app/database in Australia

    0 comments No comments