Install win11 shared printer on server 2016

Marco Cools 0 Reputation points
2023-01-26T11:38:14.1133333+00:00

Hi all,

I'm at my wit's end, looking through most of Google's "solutions'.
But even though the error message is the same, it's not quite the same situation.

Current situation.
We have some mission-critical printers that are still connected through a serial connection.
To be able to access them on the network, they are installed locally on the attached computer from there on, they're shared.
Then they are also installed on the print server so the server's application can use the printer to print.
This is a working setup.
The desktop is a Windows 10 pc, the server is Windows Server 2016.

We're in the progress of upgrading to Windows 11.
Same situation, but a different OS
Printer, and serial connection, installed on the Windows 11 desktop and shared on the network.
Here's the issue.
I can connect to the printer using another desktop (Windows 10 or 11)
I can connect to the printer using another server (Windows Server 2019)
But I can't get the printer installed on the Windows Server 2016 print server.

Error on the Windows Server 2016 Machine
User's image

Meanwhile, on the server, I can still connect or install other printers of the same kind connected to other WIndows 10 machines.

To my guess is, there's something changed in the way the communication (towards printers?) runs betwoon Server 2016 and Windows 11.

Things I've tried so far (all on the desktop as I presume this is the culprit).

  • Disabled Firewall/Antivirus
  • Granted full access rights for everyone on the printer
  • Enabled SMBv1
  • Enabled insecure guest logons (in gpedit.msc - computer config - admin templates - network - lanman Workstation)
  • Pretty my everything else you can find on Google...

I'm trying to find a solution for this as i'd rather (not yet) upgrade our printserver.

Kind regards

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,311 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,554 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Limitless Technology 43,966 Reputation points
    2023-02-01T10:57:09.08+00:00

    Hi. Thank you for your question and reaching out. I’d be more than happy to help you with your query.

    There are a few possible reasons why the printer is not being recognized by the Windows Server 2016 print server. Here are a few steps you can try to troubleshoot the issue:

    1. Check the printer name: Make sure that the printer name is entered correctly and that it matches the name of the printer on the network.
    2. Check the printer address: Ensure that the printer address is correct and that the printer is connected to the network and turned on.
    3. Check the network connection: Make sure that the print server and the printer are connected to the same network and that there are no connectivity issues.
    4. Check the printer drivers: Make sure that the correct printer drivers are installed on the print server. You can try to download the latest drivers from the printer manufacturer's website and install them on the server.
    5. Check the Firewall: Make sure the firewall is configured to allow network printing and the ports are open.
    6. Check the Print Spooler: Restarting the Print Spooler service on the server may resolve the issue.
    7. Check the Print Server Properties: Go to the Print Server Properties and make sure that the printer is shared and the share name is correct.
    8. If none of the above steps help, try to add the printer as a local printer and then connect to it as a network printer.

    If you still cannot connect to the printer, you may need to contact the printer manufacturer or a network administrator for further assistance.

    If the reply was helpful, please don’t forget to upvote or accept as answer, thank you.

    0 comments No comments

  2. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  3. Marco Cools 0 Reputation points
    2023-02-08T11:32:36.3033333+00:00

    We've solved the issue by upgrading Server 2016 to 2019.
    So it was defo some incompatibility issue...

    Thanks anyway, Marco

    0 comments No comments