Some parts of a GPO not getting applied

Arosh Wijepala 161 Reputation points
2023-01-28T09:56:55.33+00:00

I have created a group policy to allow inbound remote administration exception and to copy a powershell script to C:\temp of domain computers and run it using scheduled task. I have linked the GPO to Workstations OU and added Domain computers to Security Filtering. When I run a group policy update from the domain controller, the only thing that gets applied is, allow inbound remote administration exception. Copying file and running the script through scheduled task is not working. I appreciate some help with this.

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,528 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
5,574 questions
{count} votes

2 answers

Sort by: Most helpful
  1. JimmySalian-2011 41,631 Reputation points
    2023-01-28T11:32:28.8166667+00:00

    Hi,

    Can you check event logs and there could be permission issue with running the script remotely with the account. Did you tried manually running the script on the workstation from the remote path? Follow this link - https://woshub.com/copy-files-on-all-computers-group-policy/#:~:text=If%20you%20need%20to%20copy,to%20copy%20the%20file%20to.

    Hope this helps.

    JS

    ==

    Please Accept the answer if the information helped you. This will help us and others in the community as well.

    0 comments No comments

  2. Daisy Zhou 17,241 Reputation points Microsoft Vendor
    2023-01-30T08:11:54.66+00:00

    Hello @phantom2000,

    Thank you for posting in our Q&A forum.

    Based on the description "I have linked the GPO to Workstations OU and added Domain computers to Security Filtering.", you can run gpupdate /force on one machine in the Workstations OU.

    And run gpresult /h C:\gpo.html and click Enter. Then check the gpo setting under "Computer Details".

    If it does not work, please tell us
    1.If all the gpo settings are Computer Configuration.
    2.And how did you configure Security Filtering?
    3.If you configure Preferences and Item-targeting level?

    Hope the information above is helpful. If you have any question or concern, please feel free to let us know.

    Best Regards,

    Daisy Zhou

    ===============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments