How do we access a microphone in Teams running on a VM?

Michael Joseph 0 Reputation points
2023-01-30T21:20:00.28+00:00

Teams on our VM plays audio over local speakers, but there is no microphone. How do we solve this problem?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,928 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Dillon Silzer 54,846 Reputation points
    2023-01-30T23:17:35.14+00:00

    Hi Michael,

    I'd check that you have allowed Microphone to be used by apps:

    User's image

    Cited from https://kb.parallels.com/114055

    Also, ensure that the necessary driver for your microphone has been installed on the VM.


    If this is helpful please accept answer.

    0 comments No comments

  2. Luke Murray 10,611 Reputation points MVP
    2023-01-30T23:40:58.7466667+00:00

    Hi, Michael.

    Enable the remote audio and microphone devices over RDP

    If your VoIP application isn't detecting your microphone input or audio output, the first thing to check is your RDP client settings.

    1. Open advanced RDP settings

    In your Remote Desktop Connection window, press Show Options to access the advanced settings menu.

    Remote Desktop Connection - show options

    1. Switch to the 'Local Resources' tab and open remote audio settings

    You'll find the option underneath the Remote audio heading and the sub-text Configure remote audio settings. Press the Settings... button to continue.

    Remote Desktop Connection - remote audio settings

    1. Tick 'Record from this computer'

    While you're there, ensure Play on this computer is ticked and press OK. At this point, check your VoIP application to see if the 'Remote Output' input and output devices are available. If they still aren't working, continue to the next step.

    Remote Desktop Connection - Enable 'record from this computer'

    1. Add roles and features to your server

    Source: https://bitlaunch.io/blog/how-to-enable-remote-audio-microphone-remote-desktop/

    0 comments No comments