How to fix Error when executing stored procedure :Cannot create an instance of OLE DB provider "MSDASQL" for linked server "xx".

Phil Prich 0 Reputation points
2023-02-01T12:04:16.6533333+00:00

I am loading some data from data bricks delta table to SQL Server using linked server.

But when trying to run this from SSIS package through SQL Job failing with below error:

Error when executing stored procedure :Cannot create an instance of OLE DB provider "MSDASQL" for linked server "data bricks linked server name".

Any help ?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,224 questions
SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,403 questions
{count} votes

1 answer

Sort by: Most helpful
  1. CosmogHong-MSFT 19,901 Reputation points Microsoft Vendor
    2023-02-02T07:03:45.9466667+00:00

    Hi @Phil Prich

    Try:

    1. In SQL Server Manager, go to the Provider folder under the Server Objects folder and set the "Allow inprocess" box on the appropriate driver's properties.
    2. On the Server machine invoke the Component Services located at the Control Panel/Administrative:
    • Expand Computer Services/Computers/My Computer/DCOM Config.
    • Locate MSDAINITIALIZE and Right-Click on it.
    • Click on the Security Tab.
    • In the "Launch and Activation Permissions" click on "Customize", then click Edit.
    • Add the users or appropriate group and check all permissions (Local Launch, Remote Launch, Local Activation, Remote Activation).

    Best regards,

    Cosmog Hong


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our Documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments