What causes windows explorer to freeze on Windows 11 laptop while using remote desktop from a Windows 10 pc with multi-monitors to access the windows 11 laptop

Andre.B Full4ever 25 Reputation points
2023-02-03T02:33:12.4566667+00:00

I am using a Windows 10 pc with two monitors attached to connect over my local lan to a laptop running Windows 11. The remote connect works flawlessly but windows explorer freezes constantly during the course of me working on the laptop after 30s to 60s of having a windows file explorer or folder window open and in use leading me to force quit out of the frozen window. Another method that bypasses the freeze is I can quit the remote session and immediately reconnect and the folder window will have unfrozen every time or i can switch to login on the laptop and everything unfreezes. This works every single time which leads me to believe that this has something to do with the os and the remote connect support or drivers.

Has anyone experienced this issue and if so what was the fix?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,243 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,149 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,669 questions
0 comments No comments
{count} vote

Accepted answer
  1. Limitless Technology 44,091 Reputation points
    2023-02-03T16:50:56.65+00:00

    Hello there,

    Sounds like a task or application is running in the background and causing explorer to freeze. Also may want to disable antivirus to see if that is causing explorer to freak out.

    RDP uses both UDP and TCP protocols on port 3389. RDP protocol started using UDP from RDP v8 which was released in Windows 8 and Server 2012. The purpose of UDP is to make the connection faster and improve user experience.

    Open group policy editor

    Expand Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client. Double click the setting “Turn Off UDP On Client”. Choose Enabled option to enable this setting. Click Apply to apply the change.

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--

    1 person found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  2. workforce45 621 Reputation points
    2023-02-03T18:53:34.3666667+00:00

    Hello Andre,

    Thank you for posting this question!

    We are required to perform a general Remote Desktop troubleshooting on the client machine (Windows 11) and validate the same troubleshooting on a host machine (Windows 10). As stated above a third-party security software may also create a conflict for such operation.

    Please refer a below mentioned article for your information.

    General Remote Desktop connection troubleshooting | Microsoft Learn

    Please update with your findings!

    Regards,

    CK

    0 comments No comments

  3. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more