Unable to resize VM (D2s_v3 -> D2s_v4)

João Récio 21 Reputation points
2020-10-06T12:44:39.657+00:00

Hi,

I'm trying to resize a VM from a D2s_v3 to a D2s_v4 but I'm getting the following error:
"Unable to resize the VM '<vm_name>' since changing from resource disk to non-resource disk VM size and vice-versa is not allowed."

Any thoughts on what I need to change? :)

Thanks!

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,798 questions
{count} votes

Accepted answer
  1. KarishmaTiwari-MSFT 17,237 Reputation points Microsoft Employee
    2020-10-06T23:54:56.49+00:00

    @João Récio Thanks for providing details.

    As mentioned in this article, the limitation is, you can only resize a VM size that has a local temp disk to a VM size with local temp disk; and a VM (with no local temp disk) to a VM (with no local temp disk).

    As an example:

    DS2_V4 to DS4_V4

    DS2_V3 to DS4_V3

    In order to be able to perform the resize operation that you want to acquire, I would suggest you the following possible methods depending on what suits you the best:

    1. Re-create the VM directly with the desired D2s_v4 size.
    2. Or as an alternative to resize the VM to D4S_V3 size. ( D2S_V3 to D4S_V3 )
    3. As a workaround, you could create a snapshot from the actual disk. Create a managed disk from the snapshot. After that, create a VM from the managed disk with the D2s_v4 size.

    Let me know if you have further questions.

    ----------

    Please don’t forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    4 people found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. João Récio 21 Reputation points
    2020-10-06T14:20:05.177+00:00

    I'll add some extra info, it might help troubleshoot the issue:

    The type of subscription is Pay as you go.

    Running Ubuntu 18.04 LTS, on a 30 GiB (Premium SSD).
    Ran update and upgrade prior to shutting the VM down.

    No extensions, no CI/CD, No availability sets or failovers configured.

    Tried to resize the VM with it running and with it stopped, same error.

    I want it resized since I changed from 3 year reservation of D2s_v3 to a 3 year reservation of D2s_v4

    Feel free to ask for further information, will gladly supply it

    Thanks

    0 comments No comments