Moving Resource Caused Weird State

Tyler 1 Reputation point

Hi, and thank you for your help with this.

I've made a Windows Virtual Desktop where the domain joining user did not have AD DS credentials, so the domain join failed with the rest of the deployment succeeding.

The domain join resource then was marked as hidden, where even the resources were listed "1 of 4" instead of "1 of 5."

I moved the WVD resources to a new resource group, and everything confirmed in event monitoring as successful.

The hidden domain join was a dependency of the VM, so it moved as well, and then from what I can tell, tried to run again as part of a redeployment in the move.

It is marked as Started, but has no resultant state.

The resource group and its contents cannot be modified, and all commands affecting anything in the resource group fail.

Hours went by.

So naturally I tried to halt the subscription, thinking it might stop, or at least I might not be billed for it.

Subscription halted, VM graph activity stopped, eventually VM is offline. The Restart button is greyed out, but Start and Stop are both available. However:

Re-enabled the subscription, waited until it was propagated, and the resource group is now going between still having "error: ResourcesBeingMoved" and "error: no subscription, is read only."

What can I do? Is this a propagation issue that will just be resolved eventually? I didn't have logging set up, and can't seem to add it because the resource group is locked -- how can I check to see what's happening?

Thank you

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,380 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. jakaruna-MSFT 596 Reputation points Microsoft Employee

    If your issue is not resolved till now, Please send your subscription id to this email

    I will help you to enable a one time free support ticket for you.

    In the email subject add "for jakaruna-msft <this questions title>" and add this questions url in the email body.

    Once your issue is resolved, you can post the answer here.

    0 comments No comments