"You do not have permission to modify files in this network location." multiple users, multiple environments

NickKova 0 Reputation points
2023-02-24T17:05:38.8866667+00:00

Hello,

e

I have rather troubling issue, banging my head for over few weeks now. I will try to be as much detailed in my explanation of the issue. There are number of users in different environments (some are using Azure AD joined devices profiles, some domain joined profiles, some are local profiles). They all have issue when saving pdf/office documents from Chrome/Edge/Outlook to Desktop/Documents folders. All get the same error message: "You do not have permission to modify files in this network location. Contact the administrator per permission to make this changes". So if user clicks at first "OK", it kind off saves file with 0Kb to the location, and then if user tries saving again, it will save and overwrite file that is 0Kb with new file that is ok and can be opened and has normal size. Also in Event viewer it generates this message:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

{C2F03A33-21F5-47FA-B4BB-156362A2F239}

and APPID

{316CDED5-E4AE-4B15-9113-7055D84DCC97}

to the user AAA\peter SID (S-1-5-21-3169477740-1413890025-1457241758-1106) from address LocalHost (Using LRPC) running

in the application container Microsoft.Windows.ShellExperienceHost_10.0.19041.1949_neutral_neutral_cw5n1h2txyewy SID

(S-1-15-2-155514346-2573954481-755741238-1654018636-1233331829-3075935687-2861478708). This security permission can be

modified using the Component Services administrative tool.

(if you Google this above message, it will give you registry modification options - that fails, no success).

Now I have a different event log for each application (Chrome/Edge/Outlook), but point is that user is able to save the document but just not on the first try.

Now what I did is:

tried using local admin - fails

tried resetting permissions with icacls commands from cmd, - fails

updating/reinstalling all apps (Chrome/Edge/Office)- fails

removing all protection software from the devices (like Webroot, thought that could be the problem) - fails

adding permissions to the folder Desktop/Documents - fails (also if local admin tries same thing happens)

Now, I reinstalled/reimaged one device and that user is working just fine without this issue, but as I have over 10 users in different environments with the same issue, I am afraid reimaging all devices is not an option at the moment.

Please let me know if anyone has any clue on what to do on this issue. Thank you very much for your effort and time in advance.

And yes, all users are Windows 10 with different versions, but we can say at most the current updates.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,845 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. NickKova 0 Reputation points
    2023-03-02T12:09:39.5933333+00:00

    So no help,?

    0 comments No comments