Exchange Server 2019 installation (Mailbox servers and Edge Transport Servers)

Sheng Xu 21 Reputation points
2023-02-27T02:59:31.52+00:00

We have 5 mailbox servers and 3 edge transport servers installed in our environment ( Exchange 2019 and Windows server 2019). After installed, we run the Get-ExchangeServer command, on any Mailbox servers, we can get all 5 Mailbox servers with no Edge Transport servers. On any Edge Transport Servers, we only get the Edge Transport Server itself, with no Mailbox Servers. Above outcomes were not normal.

We'd like to see the edge transport servers can be listed via running the Get-ExchangeServer command from any mailbox server, and vice versa. Any suggestions are appreciated.

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,124 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,408 questions
0 comments No comments
{count} votes

Accepted answer
  1. Aholic Liang-MSFT 13,826 Reputation points Microsoft Vendor
    2023-02-28T07:32:39.6933333+00:00

    Hi @Sheng Xu ,

    Just wondering if you have Edge Subscription after you install Edge Transport servers?

    Testing in the lab found that we also didn't see any Edge Transport servers in the EAC before Edge Subscription:

    2023-2-27-1

    2023-2-27-2

    2023-2-27-3

    It is recommended that you refer to this link for Edge Subscription and try get-exchangeserver again to see if you can get Edge Transport servers:Edge Subscriptions | Microsoft Learn

    Hope the above suggestions are helpful to you!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Sheng Xu 21 Reputation points
    2023-02-28T10:07:56.1+00:00

    Thank you @Aholic Liang-MSFT

    We finnally fix it via having the Edge Subscription.

    Do you have any ideas about this problem: access to ECP/OWA failed with the error "http 500 internal server error"? 图片

    And If didn't prepare AD before install Exhange Server which was the cause? You know we have two sites under one root domain to deploy Exchange servers, and site 1 had prepared AD, so we didn't prepare AD when install Exchange server in site 2. Because of we use the same deploy account.

    0 comments No comments