Need earlier version of ZoomIt

Dean Stevens 20 Reputation points
2023-02-28T14:44:11.8766667+00:00

I need a copy of ZoomIt 5.XX (the current version is 6.XX). I am waiting for my organization to "approve" the latest version, but the earlier version is already on the approved list.

Can anybody help me out?

Sysinternals
Sysinternals
Advanced system utilities to manage, troubleshoot, and diagnose Windows and Linux systems and applications.
1,082 questions
{count} votes

Accepted answer
  1. Viorel 111.7K Reputation points
    2023-02-28T19:57:02.4133333+00:00

    Try some captures, which probably are reliable:

    • http://web.archive.org/web/*/https://download.sysinternals.com/files/ZoomIt.zip

    For example:

    • http://web.archive.org/web/20220315163342/https://download.sysinternals.com/files/ZoomIt.zip.

0 additional answers

Sort by: Most helpful