Can't create VM with ultra disk using portal

SCCMAdmin 86 Reputation points
2023-02-28T23:53:56.44+00:00

Hi,

I am creating an Standard_E4s_v3 at eastus2.

(ESv3-series supported: https://learn.microsoft.com/en-us/azure/virtual-machines/disks-types#ultra-disk-limitations)

Details:

BASICS:

Image: Windows 10 Pro. 22H2. x64 Gen2.

Availability options: Availability zone.

Availability zone: Zone1

DISKS:

using https://learn.microsoft.com/en-us/azure/virtual-machines/disks-enable-ultra-ssd?tabs=azure-portal#attach-an-ultra-disk (portal tab)

OS disk type: Premium SSD

Enable Ultra Disk compatibility: checked

click on Create and attach a new disk.

source type: none

change size.

disk sku: ultra disk

custom disk size: 64

disk IOPS: 19200

Disk throughput:4000

(for IOPS and Disk throughput: https://learn.microsoft.com/en-us/azure/virtual-machines/disks-types#ultra-disk-size)

key management: platform-managed key

enable shared disk: no

delete disk with vm: checked

logical sector size: 4096

REVIEW + create:

Validation failed. Required information is missing or not valid.

there is a X mark at Disks tab.

At Disks tab: message under ultra disk: Ultra disk is supported in Availability Zone(s) 1,2,3 for the selected VM size Standard*E4s*v3

I have deleted the disk and selected availability zone 2 at basics tab, the same error.

I have deleted the disk and selected availability zone 3 at basics tab, the same error.

Questions:

Is the above behavior normal?

if no

how to create a Windows VM with an attached ultra disk?

thanks in advance!

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,057 questions
0 comments No comments
{count} votes

Accepted answer
  1. Patchfox 2,896 Reputation points
    2023-03-01T00:13:43.8166667+00:00

    Hi, I hope I can help you with this question.

    To determine in which zone, you can deploy your ultra disk, run the following command:

    (Get-AzComputeResourceSku | where-object {$_.Locations.Contains($location) -and ($_.Name -eq $vmSize) -and $_.LocationInfo[0].ZoneDetails.Count -gt 0})[0].LocationInfo[0].ZoneDetails

    1 person found this answer helpful.

4 additional answers

Sort by: Most helpful
  1. TP 74,131 Reputation points
    2023-03-01T00:25:32.4033333+00:00

    Hi,

    That seems like you ran into a bug with the create VM code. Did you try opening up a new InPrivate/Incognito/Guest browser profile, signing in to the portal, and then filling out the create VM screens in sequence again fresh?

    Sometimes the order you select options and/or response/delay from underlying api while filling things out can cause you to hit a bug whereby it will give strange errors even when it should validate okay.

    As a test I just successfully created a VM that meets your specs exactly in East US 2.

    -TP

    1 person found this answer helpful.

  2. SCCMAdmin 86 Reputation points
    2023-03-01T19:04:45.2233333+00:00

    Thanks to all of you for your responses.

    I'll try both of the procedures.

    1 person found this answer helpful.
    0 comments No comments

  3. SCCMAdmin 86 Reputation points
    2023-03-01T19:06:25.5633333+00:00

    Thanks for your responses.

    I'll try both of the procedures.

    0 comments No comments

  4. SCCMAdmin 86 Reputation points
    2023-03-01T20:59:05.5533333+00:00

    Both of the responses are the answer.

    Here I can only mark 1 response as the answer.

    I miss technet forums.