How to force time synchronisation with cmos ?

CLEMENT Franck 0 Reputation points
2023-03-02T14:05:30.9166667+00:00

Hi All,

How to force the time to synchronize with the CMOS clock?

The computer is not connected to a network.

I use a time-stamped data acquisition software. I observe that Windows updates the time every 2 months or so with a 1 minute delay. I think that Windows must update its clock when the difference with the cmos clock reaches 1 minute.

I would like to force the clock update more often.

  • The command "w32Tm /query /source" indicates "Local CMOS clock".
  • The command "w32tm /resync /force" does not work and returns an error because no time data was available.

How to force the update with the CMOS clock?

Thank you

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,559 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Dave Patrick 426K Reputation points MVP
    2023-03-02T14:32:01.0266667+00:00

    The computer is not connected to a network. I observe that Windows updates the time These two seem to contradict each other. The simplest solution may be to unregister the windows time service.

    w32tm /unregister
    net stop w32time
    

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. CLEMENT Franck 0 Reputation points
    2023-03-03T08:25:52.2233333+00:00

    Thanks for this solution but, how is it possible to force the update by reading the CMOS clock?

    Because Windows seems to read the CMOS clock regularly and updates its internal software clock when the difference reaches 1 minute. I would like to know if it is possible to force this update ?

    0 comments No comments

  3. Dave Patrick 426K Reputation points MVP
    2023-03-03T13:32:22.1666667+00:00

    Something here could help.

    https://learn.microsoft.com/en-us/windows-server/networking/windows-time-service/how-the-windows-time-service-works#stopping-time-synchronization

    -

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  4. CLEMENT Franck 0 Reputation points
    2023-03-28T12:33:13.3133333+00:00

    After doing a lot of research, I still can't find an answer to this problem.

    • I stopped w32time and even disabled it
    • I disabled the scheduled time synchronization task
    • I also disabled "Hyper-V Time Synchronisation Service"
      Nothing helps, Windows changes the time by one minute every ten days or so.

    When the time changes, my software receives the message wm_timechange, which allows me to record the information, that's how I detect time changes.

    Thanks for your help