Azure Data Factory Zoho Connector not working with different scopes ?

AG 5 Reputation points
2023-03-03T21:57:33.8966667+00:00

The issue I have is similar to this one described in another question but the solution wasn't shared publicly or at least weren't clear. Here the link to the post: https://learn.microsoft.com/en-us/answers/questions/200409/azure-data-factory-zoho-connector-not-working-with

In Azure Data Factory I use Zoho connector to retrieve data from Zoho CRM. I'm using api with token authentication. I setup the linked service using Zoho connector in ADF 6 months ago and it worked fine untill 3 days ago.

When I test the connection is successfully connected but can't retrieve CRM tables (accounts, deals, etc.) but I'm receiving is this:

ERROR [HY000] [Microsoft][Zoho] (30) Error with HTTP request, response code: 400. Message: Unknown error from server

Here below a screenshot from what I'm getting.

adf zoho connector

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,520 questions
{count} votes

3 answers

Sort by: Most helpful
  1. KranthiPakala-MSFT 46,422 Reputation points Microsoft Employee
    2023-03-09T00:31:19.33+00:00

    Hi @AG ,

    Thanks for using Microsoft Q&A forum and posting your query.

    As you have mentioned it only started failing since last 3 days, I would recommend checking below options and see if any of them helps to identify the root cause.

    1. Check if the Zoho API is working properly by testing it outside of Azure Data Factory. Maybe you can try using Postman. If that works fine then we can assume something wrong on ADF side else, you will have to reach validate why API request are failing.
    2. Check if the API token is still valid and has not expired.
    3. Check if there are any recent changes in the Zoho API that might have caused the issue.
    4. If the issue persists, you can reach out to the Zoho support team for further assistance.
    5. In case if API testing works fine and token is valid, but ADF is throwing error, then I would recommend checking your IR being used. If it is SHIR then you may have to check when was the SHIR updated? Is it before the issue started or since the issue has started. Sometimes SHIR upgrades also result in such unusual behavior. If you notice there was a recent SHIR update, then try downgrading the SHIR and see if that helps to resolve the issue.
    6. If non- of the above helps, would recommend filing a support ticket for deeper investigation. And In case if you don't have a support plan, please let us know here.

    Let us know how it goes.

    Thank you

    1 person found this answer helpful.
    0 comments No comments

  2. AG 5 Reputation points
    2023-03-13T20:07:39.5566667+00:00

    Thanks KranthiPakala-MSFT for your reply. I checked all of the things you mentioned above and unfortunately, none of them worked! Fortunately for me, recently there have been another resource of development made available to myself and I took advantage of that. I used Zoho Data Prep + Zoho Analytics to load the data directly to Azure SQL Database without the need to used ADF anymore.

    1 person found this answer helpful.
    0 comments No comments

  3. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more