Microsoft Exchange Server 2019 CU11 or CU12 - Mailbox Server role isn't installed on this computer

JOE TAM 91 Reputation points
2023-03-04T16:13:34.5366667+00:00

Dear Sir,

 Customer has an Exchange 2019 Server installed with CU10 update 5 (KB5012698), when the server insert the CU11 ISO file to upgrade, error message occurred.

Error:

The Mailbox Server role isn't installed on this computer

Error:

Global updates need to be made to active directory, and this user account isn't member of the enterprise admins group.

This user account is the default domain administrator ID.

Please suggest.

Joe Tam

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,140 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,429 questions
0 comments No comments
{count} votes

Accepted answer
  1. Xuyan Ding - MSFT 7,561 Reputation points
    2023-03-06T07:23:35.1933333+00:00

    Hi @JOE TAM ,

    • First confirm with you whether the DC in the same site as the Exchange server is the schema master?Please check via SetupAssist script.
    • If not, The schema, AD and domains can be prepared directly in the site where the schema master resides.
    • Or you can move the role to the current site's server. Then run the /PrepareSchema, /PrepareAD, and /PrepareDomains commands from the command prompt and wait for AD replication to complete.

    Note that your account needs to be a member of the Schema Admins and Enterprise Admins security groups to prepare the schema.

    Please follow the steps in the article: Prepare Active Directory and domains for Exchange Server.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


2 additional answers

Sort by: Most helpful
  1. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  2. JOE TAM 91 Reputation points
    2023-07-18T04:13:30.4666667+00:00

    Solution solved by run Repadmin /replsum to check in all DC & Exchange Server. It runs properly after all replication success. Thanks.

    0 comments No comments