SharePoint List won't let me edit column properties

Barreto, Daniela 0 Reputation points
2023-03-06T10:41:05.5266667+00:00

Hi all,

I've been having issues editing a column list in SharePoint, I've tried editing by going to Settings > List Setting > Columns but it keeps sending an error message "Default Value is not a valid date", I tried all the options available (even entering "Now()" in the Calculated Value field and it is still returning the same error... I also tried opening the edit option directly in the dropdown menu in the List I want to change, and this doesn't return any error but it doesn't let me save my changes either.

I should mention that I was able to edit the columns before with no issues, I've been learning all about SharePoint and Power Automate all on my own, so any help I can get would be much appreciated.

Thank you!

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,534 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Du-MSFT 41,536 Reputation points Microsoft Vendor
    2023-03-07T06:57:59.2833333+00:00

    What is the version of SharePoint? Whether this issue occurs on all columns? Whether this column has JSON formatting.

    Based on your description, I understand that when you edit a date and time column, it shows "Default Value is not a valid date" error message.

    Please provide some screenshots about the column settings to further troubleshooting.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.