I cannot start my VM. Created an image to clone from but now cannot start the source VM

William Bertolotti 0 Reputation points
2023-03-06T13:30:32.49+00:00

I have a VM that was running fine. I wanted to clone to a 2nd VM. I created an image and tried to create the 2nd VM but that failed to deploy. I removed the 2nd VM and created manually. When I tried to start up both VMs, the new one started but the original VM failed saying it is generalized and a Start VM command wont work. All my applications and setups are on that VM and I need to recover it and be able to start it

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,242 questions
Azure VMware Solution
Azure VMware Solution
An Azure service that runs native VMware workloads on Azure.
320 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Jackson Martins 9,796 Reputation points MVP
    2023-03-06T13:35:17.14+00:00

    Hi!

    When you generalize a VM, you can no longer use it, only copies from it.

    User's image

    Reference: https://learn.microsoft.com/en-us/azure/virtual-machines/generalize#windows

    1 person found this answer helpful.

  2. kobulloc-MSFT 23,736 Reputation points Microsoft Employee
    2023-03-10T03:19:11.0133333+00:00

    Hello, @William Bertolotti !

    How do I clone a VM?

    You can make a generalized copy of a VM however generalizing a VM will remove machine specific information such as personal account and security information as mentioned by @Jackson Martins .

    Snapshots (as used in disaster recovery) create a full, read-only copy of a virtual hard disk (VHD) which you can use as a point in time backup (or a clone) of your VM. You create a snapshot, then create a managed disk from the snapshot.

    Luis Beltran has posted a great blog that covers the process with step-by-step screenshots:

    https://dev.to/icebeam7/cloning-azure-vms-1889

    I hope this helps!

    0 comments No comments