Are links updated when bulk uploading to Teams?

Duffy Cavanaugh 0 Reputation points
2023-03-06T18:13:42.5+00:00

I am a Program Manager for military construction for the National Guard - I track project packets to support throughput funding for construction. Many documents come to me through the project stakeholder, I am a reviewer in this process, and the documents must be uploaded to a Teams site (private channel) for each project. In my document library in MS Teams I have a main folder for each individual project - each set of folders are set up identical - other than the project number which is the unique identifier for each set of folders. The checklist is set up and displayed via excel tab at the top of the channel by project number. Links on the left column correspond with the folder in the document library that the stakeholder must drop their documents into. In the past, when I set up a new project in the channel files tab, the links from my laptop automatically updated to the new location on the SharePoint server from within the Excel document. Now they are not doing it on my latest project uploads. What has changed?

I have 67 lines (documents) on my checklist for my plans reviewers to look at, these lines dump into a file tree under the project number; then 8 sub folders; and a few other second subfolder under a select few subfolders. Path overall doesn't change - other than from my local desktop/laptop to the MS Teams SharePoint server.

Oh, one other item, SOME of the links update and can open the appropriate library locations in the folders, but others do not update. Second Oh: When I open the excel document on my desktop app, all links are thee and work. But my stakeholders access this mainly by MS Teams app. This frustrates me. Why is it so inconsistent?

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,033 questions
Excel
Excel
A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.
1,441 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Kael Yao-MSFT 37,491 Reputation points Microsoft Vendor
    2023-03-07T05:27:57.6966667+00:00

    Hi @Duffy Cavanaugh

    Sorry not sure if I understand the situation correctly.

    To my understanding,

    • you are creating a local excel file named checklist (which has hyperlinks pointing to folders) and the corresponding folders with subfolders for each project.
    • upload the checklist excel file and folders to the Sharepoint site.
    • the hyperlinks stop working in Sharepoint/Teams, but are working locally

    If I misunderstood it, please feel free to correct me.


    Based on my test, it may be the expected behavior that hyperlinks don't work after the files are uploaded to Sharepoint.

    As no matter you are using absolute path or relative path in hyperlinks on your local computer, once you upload the excel file and folders to Sharepoint, the folder structure gets changed so the hyperlinks would no longer work.

    Oh, one other item, SOME of the links update and can open the appropriate library locations in the folders, but others do not update.

    Are you syncing the Sharepoint site with your local folders?

    And you first create the excel file also the folders locally and later synced these files to Sharepoint site?

    Based on my test, in this way when you create hyperlinks it would point to the file path in Sharepoint.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. 2023-03-07T09:04:03.4233333+00:00

    You must use Microsoft tools for example Microsoft teams

    0 comments No comments

  3. 2023-03-07T09:27:54.71+00:00

    You must Copy the link and open it on the browser to make sure that the meeting link is there the defect may be from the browser and make sure the internet connection

    0 comments No comments