UWP sideload install failed due to Microsoft.NET.CoreFramework.2.2

Flaubert TAGU 1 Reputation point
2023-03-07T13:09:58.69+00:00

I currently have some issues distributing and UWP app I developped. I tried to install the application on the same computer on which it has been developped but in another user account which does not have administrator priviledges.

The main issue is caused by the package "Microsoft.NET.CoreFramework.2.2".

(1) First I tried to install it simply, (2) then I tried to add in package.appxmanifest the following line:

<Dependencies>
    <PackageDependency Name="Microsoft.NET.CoreRuntime.2.2" MinVersion="2.2.27902.3" Publisher="CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US" />
</Dependencies>

I do not know if it 'Minversion' or 'Publisher' are correct since I did not found any information about it. I based the declarations on https://learn.microsoft.com/en-us/troubleshoot/developer/visualstudio/cpp/libraries/c-runtime-packages-desktop-bridge which has already been integrated since the package was causing the same issue.

I currently have the following issue for this release published:

Image 1:

WindowsAppCertif failed

Image 2:

Program installation error

Previously, I tried to follow the answer provided in a similar topic https://learn.microsoft.com/en-us/answers/questions/79515/uwp-app-(x64)-microsoft-net-coreruntime-2-2-appx-f

The answer provide did not helped me to solve the issue at all.

More information about the configuration:

(1) Computer environment: Windows 10 Version 22h2 build 19045.2546

(2) UWP settings :

(a) Target version: Windows 10 version 2004 build 19041

(b) Minimal target: Windows 10 version 1903 build 18362

I will gladly provide any other useful information which could lead you to help me.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,560 questions
Universal Windows Platform (UWP)
{count} votes

2 answers

Sort by: Most helpful
  1. Flaubert TAGU 1 Reputation point
    2023-03-09T19:55:25.4733333+00:00

    I found an alternative to make sure that the application is installed.

    However, it comes with an additionnal error. I tried to install the application using "install.ps1" file. The issue using this process is that the application event if it is installed from the session of the user without administrator priviledges, the application is only installed inside the administrator session.

    Any idea how it works?

    0 comments No comments

  2. Flaubert TAGU 1 Reputation point
    2023-03-10T19:48:09.26+00:00

    I found the error in the solution.

    The issue came from the wpf application used to install the package. Since the certificated was needed to be install the package in the local machine, I was forcing the wpf application to be launched with administrator priviledges. I was using a cmd.exe to silently launch powershell command.

    Later, I just used the powershell command generated by visual studio to install the package, but I did not remove this cmd.exe command.

    I think the issue came from there. I suppose running the powershell command to install the package using the admin priviledges made the UWP app available inside the administator session and not the opened session.

    After removing this constraint (security), the package has successfully installed by the application.